PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type nfcDonnée
  • Réinitialisation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le type nfcDonnée permet de décrire et manipuler les données d’une variable de type nfcTag. Les caractéristiques de ces données peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Versions 24 et supérieures
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Nouveauté 24
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Exemple
Android
// Ecrit une url dans un tag NFC
tag est un nfcTag
url est une nfcDonnée
url..Type = nfcURI
url..Contenu = "www.pcsoft.com"
Ajoute(tag, url)
NFCEcritTag(tag)
SI ErreurDétectée = Vrai ALORS
Erreur("Echec de l’écriture sur le tag NFC.", ErreurInfo())
FIN
Android
// Sauvegarde une image dans un tag NFC
tag est un nfcTag
url est une nfcDonnée
url..Type = nfcMedia
url..Contenu = fChargeBuffer(ComplèteRep(SysRepCarteStockage()) + "image.png")
url..TypeMIME = "image/png"
Ajoute(tag, url)
NFCEcritTag(tag)
SI ErreurDétectée = Vrai ALORS
Erreur("Echec de l’écriture sur le tag NFC.", ErreurInfo())
FIN
// Lecture des données d’un tag NFC
tag est un nfcTag
tag = NFCLitTag()
SI PAS ErreurDétectée = Vrai ALORS
POUR TOUTE donnée DE tag..Donnée
SELON donnée..Type
CAS nfcTexte
sLangue est une chaîne = LangueVersNom(donnée..Langue)
sTexte est une chaîne = donnée..Contenu
CAS nfcURI
SI ChaîneCommencePar(donnée..Contenu, "http") ALORS
NavigateurLanceAppli(donnée..Contenu)
FIN
CAS nfcMedia
SI donnée..TypeMIME ~= "image/png" ALORS
fSauveBuffer(ComplèteRep(SysRepCarteStockage()) + ...
"image.png", donnée..Contenu)
FIN
FIN
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type nfcDonnée

Les propriétés suivantes peuvent être utilisées pour manipuler une donnée d'un tag NFC :
Nom de la propriétéType manipuléEffet
ContenuBinaire / BufferContenu de la donnée. Son type dépend de la valeur de la propriété ..Type.
Si la propriété ..Type correspond à :
  • la constante nfcTexte:
    • Android la propriété ..Contenu peut être une chaîne Ansi ou Unicode.
    • Versions 24 et supérieures
      iPhone/iPad la propriété ..Contenu est une chaîne Unicode.
      Nouveauté 24
      iPhone/iPad la propriété ..Contenu est une chaîne Unicode.
      iPhone/iPad la propriété ..Contenu est une chaîne Unicode.
    Android Lors de l'écriture du Tag NFC :
    • si la propriété ..Contenu est une chaîne Ansi, le texte sera encodé en UTF8,
    • si la propriété ..Contenu est une chaîne Unicode, le texte sera encodé en UTF16.
  • la constante nfcURI, la propriété ..Contenu correspond à une chaîne Ansi.
  • la constante nfcMédia, la propriété ..Contenu correspond à un buffer.
    L'interprétation des données du buffer dépend du type MIME associé à la variable nfcDonnée.
  • la constante nfcVide : Une erreur fatale sera déclenchée en cas de tentative de modification de la propriété ..Contenu.
  • la constante nfcInconnu : Une erreur fatale sera déclenchée en cas de tentative de modification de la propriété ..Contenu.
iPhone/iPad Cette propriété est disponible uniquement en lecture.
LangueEntierLangue du texte stockée dans la propriété ..Contenu.
Cette propriété doit être utilisée uniquement lorsque la variable de type nfcDonnée est de type nfcTexte. Une erreur fatale sera déclenchée en cas de lecture ou de modification de la propriété ..Langue d’une variable nfcDonnée d'un type différent.
Par défaut, la propriété ..Langue est initialisée avec la langue courante de l’application.
Pour connaître :
iPhone/iPad Cette propriété est disponible uniquement en lecture.
TypeConstante de type EntierType de données, correspondant à une des constantes suivantes :
  • nfcTexte : Données de type texte.
  • nfcURI : Données de type URI (Uniform Ressource Identifier). Peut correspondre à :
    • l’url d’une page web (http://www.pcsoft.fr),
    • une adresse FTP (ftp://ftp.pcsoft.fr/),
    • un numéro de téléphone (tel:0123456789),
    • une adresse mail (mailto:adresse@mail.com), etc.
      Il est possible d’utiliser la fonction LanceAppliAssociée avec cette URI (par exemple pour ouvrir le navigateur lorsque l’URI correspond à l’adresse d’un site Web).
  • nfcMedia : Données de type média. Peut correspondre à toute ressource identifiée par un type MIME (image, vidéo, document, etc.).
  • nfcVide : Type vide. Ce type est utilisé en particulier lors de la création d’une variable de type nfcDonnée tant qu’aucun type de donnée n’a été spécifié.
  • nfcInconnu : Type inconnu.
Remarque importante : La modification du type d’une variable de type nfcDonnée entraîne la réinitialisation de son contenu. Il est donc important de spécifier le type avant le contenu.
iPhone/iPad Cette propriété est disponible uniquement en lecture.
TypeMIMEChaîne de caractèresType MIME de la ressource stockée dans la propriété ..Contenu.
Le type MIME spécifié peut soit correspondre :
  • soit à un type MIME standard. Plus de 150 types sont définis dans la norme de communication MIME (disponible sur Internet). Les valeurs les plus courantes sont :
    • "application/pdf" : document au format PDF (*.pdf)
    • "text/html" : page HTML (*.htm, *.html)
    • "text/plain": fichier texte (*.txt)
    • "image/gif" : image au format GIF (*.gif)
    • "image/jpeg" : image au format JPEG (*.jpg, *.jpeg)
    • "video/mpeg" : vidéo au format MPEG (*.mpg, *.mpeg)
    • "application/msword" : fichier Word.
    • "application/vnd.ms-excel" : fichier Excel.
  • soit à un type personnalisé.
La propriété ..TypeMIME ne doit être utilisée que lorsque la variable nfcDonnée est de type nfcMedia. Une erreur fatale sera déclenchée en cas de lecture ou de modification de la propriété ..TypeMIME d’une variable nfcDonnée d'un type différent.
iPhone/iPad Cette propriété est disponible uniquement en lecture.

Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>

Réinitialisation

Pour réinitialiser le contenu d’une variable de type nfcDonnée, il est possible d’utiliser la fonction VariableRAZ.
Version minimum requise
  • Version 18
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire