PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
La propriété ..SaisieDirecteRDV permet de savoir et d'indiquer si l’utilisateur peut modifier directement le titre d’un rendez-vous :
  • dans un champ Planning,
  • WINDEVWEBDEV - Code ServeurPHP dans un champ Agenda. dans un champ Agenda.
Cette propriété correspond à l'option "Autoriser la saisie directe d'un rendez-vous" présente dans l'onglet "Détail" de la fenêtre de description des champs Planning et Agenda.
Versions 18 et supérieures
WEBDEV - Code Serveur Cette propriété est désormais disponible en WEBDEV Serveur (Windows et Linux).
WEBDEV - Code ServeurPHP Cette propriété est désormais disponible pour les sites PHP.
Nouveauté 18
WEBDEV - Code Serveur Cette propriété est désormais disponible en WEBDEV Serveur (Windows et Linux).
WEBDEV - Code ServeurPHP Cette propriété est désormais disponible pour les sites PHP.
WEBDEV - Code Serveur Cette propriété est désormais disponible en WEBDEV Serveur (Windows et Linux).
WEBDEV - Code ServeurPHP Cette propriété est désormais disponible pour les sites PHP.
Versions 21 et supérieures
iPhone/iPad Cette propriété est désormais disponible pour les champs Planning dans les applications iPhone/iPad.
Android Cette propriété est désormais disponible pour les champs Planning dans les applications Android.
Nouveauté 21
iPhone/iPad Cette propriété est désormais disponible pour les champs Planning dans les applications iPhone/iPad.
Android Cette propriété est désormais disponible pour les champs Planning dans les applications Android.
iPhone/iPad Cette propriété est désormais disponible pour les champs Planning dans les applications iPhone/iPad.
Android Cette propriété est désormais disponible pour les champs Planning dans les applications Android.
Versions 24 et supérieures
Android Cette propriété est désormais disponible pour les champs Agenda dans les applications Android.
iPhone/iPad Cette propriété est désormais disponible pour les champs Agenda dans les applications iPhone/iPad.
Nouveauté 24
Android Cette propriété est désormais disponible pour les champs Agenda dans les applications Android.
iPhone/iPad Cette propriété est désormais disponible pour les champs Agenda dans les applications iPhone/iPad.
Android Cette propriété est désormais disponible pour les champs Agenda dans les applications Android.
iPhone/iPad Cette propriété est désormais disponible pour les champs Agenda dans les applications iPhone/iPad.
Exemple
// Gestion des options d'un champ Planning
SI gbModeModif = Vrai ALORS
PLN_MonPlanning..DéplacementRDV = Vrai
PLN_MonPlanning..SaisieDirecteRDV = Vrai
PLN_MonPlanning..SélectionPériode = Vrai
SINON
PLN_MonPlanning..DéplacementRDV = Faux
PLN_MonPlanning..SaisieDirecteRDV = Faux
PLN_MonPlanning..SélectionPériode = Faux
FIN
WINDEVWEBDEV - Code ServeurPHP
// Gestion des options d'un champ Agenda
SI gbModeModif = Vrai ALORS
AGD_MonAgenda..DéplacementRDV = Vrai
AGD_MonAgenda..SélectionPériode = Vrai
AGD_MonAgenda..SaisieDirecteRDV = Vrai
SI PAS EnModeAndroid() _ET_ PAS EnModeiOS() ALORS
AGD_MonAgenda..ModificationDuréeRDV = Vrai
FIN
SINON
AGD_MonAgenda..DéplacementRDV = Faux
AGD_MonAgenda..SélectionPériode = Faux
AGD_MonAgenda..SaisieDirecteRDV = Faux
SI PAS EnModeAndroid() _ET_ PAS EnModeiOS() ALORS
AGD_MonAgenda..ModificationDuréeRDV = Faux
FIN
FIN
// Gestion des options d'un champ Agenda
SI gbModeModif = Vrai ALORS
AGD_MonAgenda..DéplacementRDV = Vrai
AGD_MonAgenda..SélectionPériode = Vrai
AGD_MonAgenda..SaisieDirecteRDV = Vrai
SI PAS EnModeAndroid() _ET_ PAS EnModeiOS() ALORS
AGD_MonAgenda..ModificationDuréeRDV = Vrai
FIN
SINON
AGD_MonAgenda..DéplacementRDV = Faux
AGD_MonAgenda..SélectionPériode = Faux
AGD_MonAgenda..SaisieDirecteRDV = Faux
SI PAS EnModeAndroid() _ET_ PAS EnModeiOS() ALORS
AGD_MonAgenda..ModificationDuréeRDV = Faux
FIN
FIN
Syntaxe

Savoir si l'utilisateur peut saisir directement un rendez-vous Masquer les détails

<Résultat> = <Champ>..SaisieDirecteRDV
<Résultat> : Booléen
  • Vrai si l'utilisateur peut saisir directement un rendez-vous,
  • Faux si l'utilisateur ne peut pas saisir directement un rendez-vous.
<Champ> : Nom de champ
Nom du champ manipulé. Ce champ peut correspondre à :
  • WINDEVWEBDEV - Code ServeurPHP un champ Agenda. un champ Agenda.
  • un champ Planning.

Rendre ou non les rendez-vous directement saisissables par l'utilisateur Masquer les détails

<Champ>..SaisieDirecteRDV = <Déplaçable>
<Champ> : Nom de champ
Nom du champ manipulé. Ce champ peut correspondre à :
  • WINDEVWEBDEV - Code ServeurPHP un champ Agenda. un champ Agenda.
  • un champ Planning.
<Déplaçable> : Booléen
  • Vrai pour que l'utilisateur puisse directement saisir les rendez-vous,
  • Faux pour l'utilisateur ne puisse pas saisir directement les rendez-vous.
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire