PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Pré-requis
  • Les différentes étapes de la création d'une application iPhone/iPad
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Pré-requis
Pour développer une application WINDEV Mobile pour iPhone/iPad, il est nécessaire de posséder :
  • 1 PC
  • 1 MAC
  • 1 iPhone et/ou iPad (optionnel)
Pourquoi un PC ?
WINDEV Mobile 24 est une application Windows, utilisable sous Windows XP, Vista, 7, 8, 10.
L'application sera créée sur le PC avant d'être compilée sur un MAC (Projet, Analyse, Fenêtres, ...).
Ce PC ne nécessite aucune installation d'outils Mac/Apple.
Astuce : Un PC n'est pas obligatoire. En effet, il est possible d'installer un logiciel de virtualisation de type "Parallels Desktop" sur un MAC pour exécuter Windows sur MAC. Dans ce cas, il est possible d'exécuter WINDEV Mobile sur MAC.
Pourquoi un MAC ?
Un MAC est nécessaire car il faut compiler le projet généré sur le PC dans un compilateur spécifique pour générer des applications iOS. La version minimum du système d'exploitation doit être de 10.6 (Snow leopard).
Xcode est le compilateur MAC pour générer des programmes qui fonctionnent sous le système iOS (c'est-à-dire qui s'exécutent sur iPhone et iPad).
La version minimum de Xcode préconisée doit être la 4.3.La version minimum de Xcode préconisée doit être la 5.La version minimum de Xcode préconisée doit être la 7.
XcodeiOS
v 4.02iOS SDK 4.3 / Snow leopard
v 4.1iOS SDK 4.3 / Lion
v 4.2iOS SDK 5 / Lion
v 4.3iOS SDK 5 / Lion
v 4.4iOS SDK 5 / Lion
v 4.5iOS SDK 6 / Lion
v 4.6iOS SDK 6 / Lion
v 5iOS SDK 7 / Mountain lion
v 6iOS SDK 7 / Mountain lion
v 7iOS SDK 7 / Mountain lion
ATTENTION : Si vous utilisez WINDEV Mobile 17
La version 4.5 de Xcode ne doit pas être utilisée sous peine d'obtenir le retour suivant : no architecture to compile for (ARCHS=armv6 , VALID_ARCHS=armv7)
En effet, afin d'être compatible avec l'iPhone 3 notamment, les projets Xcode générés par WINDEV Mobile 24 sont adaptés au jeu d'instructions des processeurs ARMV6 minimum. Dans la version 4.5 de Xcode, Apple a supprimé le support de ARMV6, imposant ARMV7 en version minimale (donc plus de support de l'iPhone 3/3G).
Attention, ce changement de Apple concerne la compilation des projets : il n'a pas d'incidence sur l'exécution. Une application WINDEV Mobile 24 compilée avec Xcode 4.1 à 4.4 pourra parfaitement s'exécuter sous iOS6.
Où se procurer Xcode ?
Pour installer le compilateur Xcode, il suffit d'avoir un compte iTunes (et donc un identidiant Apple). Le téléchargement de xCode se fait alors gratuitement depuis le Mac App Store (au moment de la rédaction de ce document).
Remarque : Il est également possible de s'inscrire auprès de Apple sur le iOS and Mac Developer Programs comme développeur d'applications pour Mac, iPhone, iPad. Cette inscription est nécessaire pour déployer vos applications. Vous pourrez ainsi télécharger une version de Xcode. Ce téléchargement est gratuit (au moment de la rédaction de ce document).
Les différentes étapes de la création d'une application iPhone/iPad
Pour développer une application qui fonctionnera sous iOS iPhone et/ou iPad, les différentes étapes sont les suivantes :
Remarque : La configuration minimale requise est la suivante :
  • Matériel : iPhone 3GS, iPAD 1, iPod Touch 3ème génération minimum
  • Système : iOS version 4 minimumSystème : iOS version 6 minimum
Vous avez utilisé la pré-version : consultez la liste des modifications pour le développement d'applications iPhone/iPad.
Version minimum requise
  • Version 17
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire