PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
SaaSConnecte (Fonction)
En anglais : SaaSConnect
Authentifie un utilisateur d'un site SaaS auprès du webservice SaaS gestionnaire du site.
Remarque : Lorsque la connexion est établie avec SaaSConnecte, il est possible d'accéder à tous les sites. La fonction SaaSVérifieService permet de vérifier les droits d'accès.
Exemple
// Connexion au Webservice en charge du site
SI SaaSConnecte(SAI_LOGIN, SAI_PASSWORD) = Faux ALORS
SI ErreurDétectée = Vrai ALORS
sMessageErreur = RC + ErreurInfo(errComplet)
RENVOYER sMessageErreur
SINON
RENVOYER "Connexion au site SaaS refusée."
FIN
FIN
 
// On passe une syntaxe spécifique (sans paramètres) pour indiquer que l'on teste l'accès au site
// Le client a au moins un abonnement valide à au moins un service du site
SI SaaSVérifieService() = Faux ALORS
SI ErreurDétectée = Vrai ALORS
sMessageErreur = RC + ErreurInfo(errComplet)
RENVOYER sMessageErreur
SINON
RENVOYER "Connexion au service SaaS du site refusée."
FIN
FIN
 
// Utilisation de la connexion à la base HFSQL Client/Serveur ou Classic
// définie dans l'administrateur SaaS sur le serveur, pour les données du site.
SI HChangeConnexion("*", SaaSConnexionClient()) = Faux ALORS
sMessageErreur = HErreurInfo(hErrComplet)
RENVOYER sMessageErreur
FIN
 
RENVOYER "Connexion OK"
Syntaxe
<Résultat> = SaaSConnecte(<Utilisateur> , <Mot de passe> [, <Webservice>])
<Résultat> : Booléen
  • Vrai si l'authentification a réussi,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Utilisateur> : Chaîne de caractères
Nom de connexion de l'utilisateur SaaS.
<Mot de passe> : Chaîne de caractères
Mot de passe de l'utilisateur SaaS.
<Webservice> : Chaîne de caractères optionnelle
Webservice à utiliser. Ce paramètre correspond :
  • soit au nom de l'hôte du webservice SaaS (par exemple, "Machine", "Machine.MonReseau.fr" , "http://Mondomaine.com").
  • soit à l'URL complète du webservice SaaS (par exemple, "http://domaine.com/WDSAAS280_WEB/WDSaaS280.awws").
Par défaut, la connexion se fera au webservice SaaS installé avec le serveur d'application WEBDEV sur la machine locale.
Remarques
  • Si la fonction SaaSConnecte est exécutée plusieurs fois, une déconnexion implicite est effectuée à chaque fois (fonction SaaSDéconnecte).
  • Lorsque la connexion a été réalisée avec la fonction SaaSConnecte, le webservice SaaS teste périodiquement la validité de la connexion par un appel automatique de la fonction SaaSEstConnecté toutes les 4 minutes.
  • Si l'authentification est réussie, les prochaines fonctions SaaSxx utiliseront implicitement le compte SaaS précisé dans le dernier appel à la fonction SaaSConnecte. Ce contexte d'exécution sera fermé avec la fonction SaaSDéconnecte.
  • Pour renforcer la sécurité, il est conseillé d'utiliser le protocole HTTPS à la fois pour accéder à la page contenant l'appel à la fonction SaaSConnecte mais également dans l'URL du Webservice. Le serveur doit être configuré pour accepter ce protocole.
  • Si le Webservice est accédé en HTTPS, le certificat SSL utilisé ne doit pas produire d'exception de sécurité.
  • La fonction SaaSChangeMotDePasse permet de modifier le mot de passe de l'utilisateur connecté.
Composante : wd280com.dll
Version minimum requise
  • Version 15
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire