PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 24 !
  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
<Variable sfConnexion>.Supprime (Fonction)
En anglais : <sfConnection variable>.Delete
Supprime des enregistrements d'une base de données Salesforce.
Versions 20 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 20
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 24 et supérieures
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI Cnx.Connecte() = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN

ResRequête est un sfRésultatExécuteRequête
ResRequête = Cnx.ExécuteRequête("SELECT Date__c,Miles__c,Contact__c FROM Mileage__c")

MonEnregistrement est un sfObjet
POUR TOUT MonEnregistrement DE ResRequête..Objet
 Trace("---- Type : " + MonEnregistrement..TypeObjet + " | ID : " + MonEnregistrement..ID)
 Trace(MonEnregistrement..Date__c + " / " + MonEnregistrement..Miles__c + ...
 " / " + MonEnregistrement..Contact__c)
FIN

//Suppression d'un objet
tabSuppr est un tableau de chaînes
tabSuppr.Ajoute(ResRequête..Objet[1]..ID)

ResSuppr est un tableau de sfRésultatSupprime
ResSuppr = Cnx.Supprime(tabSuppr)
POUR TOUT res DE ResSuppr
Trace("ID : " + res..ID + " - Suppression = " + res..Succès)
FIN
Syntaxe
<Résultat> = <Connexion Salesforce>.Supprime(<Enregistrements à supprimer>)
<Résultat> : Variable de type Tableau
Tableau de variables de type sfRésultatSupprime contenant les données supprimées.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser
<Enregistrements à supprimer> : Variable de type Tableau
Tableau de chaînes de caractères contenant les identifiants Salesforce des enregistrements à supprimer.
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.
Composante : wd240ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire