PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 24 !
  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
<Variable sfConnexion>.Restaure (Fonction)
En anglais : <sfConnection variable>.Undelete
Restaure des enregistrements Salesforce précédemment effacés.
Versions 20 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 20
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 24 et supérieures
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI Cnx.Connecte() = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN

ResRecupSuppr est un sfRésultatRechercheSupprimé
ResRecupSuppr = Cnx.RechercheSupprimé("Mileage__c", "20090101", "20090131")

tabRestaure est un tableau de chaînes
MonEnregistrement est un sfEnregistrementSupprimé
POUR TOUT MonEnregistrement DE ResRecupSuppr..EnregistrementSupprimé
tabRestaure.Ajoute(MonEnregistrement..ID)
FIN

ResRestaure est un tableau de sfRésultatRestaure
ResRestaure = Cnx.Restaure(tabRestaure)
MonEnregRestauré est un sfRésultatRestaure
POUR TOUT MonEnregRestauré DE ResRestaure
Trace("ID = " + MonEnregRestauré..ID)
Trace("Succès = " + MonEnregRestauré..Succès)
FIN
Syntaxe
<Résultat> = <Connexion Salesforce>.Restaure(<Enregistrements à restaurer>)
<Résultat> : Tableau de sfRésultatRestaure
Tableau de variables de type sfRésultatRestaure contenant les enregistrements restaurés.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Enregistrements à restaurer> : Tableau de chaînes
Nom du tableau de chaînes de caractères contenant les identifiants Salesforce des enregistrements à restaurer.
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.
Composante : wd240ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire