PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type sfRésultatRestaure
  • Fonctions manipulant le type sfRésultatRestaure
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
sfRésultatRestaure (Type de variable)
En anglais : sfUndeleteResult (Type of variable)
Le type sfRésultatRestaure permet de connaître le résultat de la fonction SFRestaure. Les caractéristiques de ce résultat peuvent être connues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Versions 20 et supérieures
WINDEVLinux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Nouveauté 20
WINDEVLinux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
WINDEVLinux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN

ResRecupSuppr est un sfRésultatRechercheSupprimé
ResRecupSuppr = SFRechercheSupprimé(Cnx, "Mileage__c", "20090101", "20090131")

tabRestaure est un tableau de chaînes
MonEnregistrement est un sfEnregistrementSupprimé
POUR TOUT MonEnregistrement DE ResRecupSuppr..EnregistrementSupprimé
Ajoute(tabRestaure, MonEnregistrement..ID)
FIN

ResRestaure est un tableau de sfRésultatRestaure
ResRestaure = SFRestaure(Cnx, tabRestaure)
MonEnregRestauré est un sfRésultatRestaure
POUR TOUT MonEnregRestauré DE ResRestaure
Trace("ID = " + MonEnregRestauré..ID)
Trace("Succès = " + MonEnregRestauré..Succès)
FIN
Remarques

Propriétés spécifiques à la description des variables de type sfRésultatRestaure

Les propriétés suivantes peuvent être utilisées pour manipuler le résultat de la fonction SFRestaure :
NomType manipuléEffet
ErreurTableau de sfErreurCompte-rendu d'erreurs.
IDChaîne de caractèresIdentifiant Salesforce de l'enregistrement restauré.
Cette propriété est disponible en lecture uniquement.
SuccèsBooléen
  • Vrai si la restauration a été effectuée,
  • Faux dans le cas contraire.
Cette propriété est disponible en lecture uniquement.

Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>

Fonctions manipulant le type sfRésultatRestaure

Versions 14 et supérieures
SFRestaure
Nouveauté 14
SFRestaure
SFRestaure
Restaure des enregistrements Salesforce précédemment effacés.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire