PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Continue d'exécuter une requête SOQL (Salesforce Object Query Language) sur les enregistrements d'une base de données Salesforce. La requête a été exécutée avec la fonction SFExécuteRequête.
Versions 20 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 20
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 24 et supérieures
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
ResRequête est un sfRésultatExécuteRequête
ResRequête = SFExécuteRequête(Cnx, "SELECT Date__c,Miles__c,Contact__c FROM Mileage__c")

BOUCLE
MonEnregistrement est un sfObjet
POUR TOUT MonEnregistrement DE ResRequête..Objet
Trace("---- Type : " + MonEnregistrement..TypeObjet + " | ID : " + MonEnregistrement..ID)
Trace(MonEnregistrement..Date__c + " / " + ...
MonEnregistrement..Miles__c + " / " + MonEnregistrement..Contact__c)
FIN
ResRequête = SFAvanceRequête(Cnx, ResRequête..LocalisationRequête)
À FAIRE TANTQUE PAS ResRequête..Fini

POUR TOUT MonEnregistrement DE ResRequête..Objet
Trace("---- Type : " + MonEnregistrement..TypeObjet + ...
" | ID : " + MonEnregistrement..ID)
Trace(MonEnregistrement..Date__c + " / " + ...
MonEnregistrement..Miles__c + " / " + MonEnregistrement..Contact__c)
FIN
Syntaxe
<Résultat> = SFAvanceRequête(<Connexion Salesforce> , <Localisation de la requête>)
<Résultat> : Variable de type sfRésultatExécuteRequête
Variable de type sfRésultatExécuteRequête contenant les données résultat, notamment les enregistrements Salesforce correspondant au résultat de la requête.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Localisation de la requête> : Chaîne de caractères Unicode (entre guillemets)
Chaîne permettant d'identifiant la requête. Cette chaîne est obtenue grâce à la propriété ..LocalisationRequête de la dernière variable sfRésultatExécuteRequête reçue.
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.
Composante : wd240ggl.dll
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire