PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
SFVideCorbeille (Fonction)
En anglais : SFEmptyRecycleBin
Vide les enregistrements spécifiés de la corbeille Salesforce.
Remarque : Au bout de 30 jours, les éléments présents dans la corbeille Salesforce sont automatiquement supprimés de la corbeille.
Versions 20 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
Nouveauté 20
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
Versions 24 et supérieures
Linux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
Linux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Linux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
ResRequête est un sfRésultatExécuteRequête
ResRequête = SFExécuteRequête(Cnx, "SELECT Date__c,Miles__c,Contact__c FROM Mileage__c")

MonEnregistrement est un sfObjet
POUR TOUT MonEnregistrement DE ResRequête..Objet
Trace("---- Type : " + MonEnregistrement..Type + " | ID : " + MonEnregistrement..ID)
Trace(MonEnregistrement..Date__c + " / " + MonEnregistrement..Miles__c + " / " + ...
MonEnregistrement..Contact__c)
FIN

// Suppression d'un objet
tabSuppr est un tableau de chaînes
Ajoute(tabSuppr, ResRequête..Objet[1]..ID)

tabResSuppr est un tableau de sfRésultatSupprime
tabResSuppr = SFSupprime(Cnx, tabSuppr)
POUR TOUT res DE tabResSuppr
Trace("ID : " + res..ID + " - Suppression = " + res..Succès)
FIN

tabResVideCorb est un tableau de sfRésultatVideCorbeille
tabResVideCorb = SFVideCorbeille(Cnx, tabSuppr)
POUR TOUT res DE tabResVideCorb
Trace("ID : " + res..ID + "- VideCorbeille  = " + res..Succès)
FIN
Syntaxe
<Résultat> = SFVideCorbeille(<Connexion Salesforce> , <Enregistrements à supprimer>)
<Résultat> : Tableau de sfRésultatVideCorbeille
Tableau de variables de type sfRésultatVideCorbeille contenant les enregistrements supprimés de la corbeille.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Enregistrements à supprimer> : Variable de type Tableau
Tableau de chaînes de caractères contenant les identifiants Salesforce des enregistrements à supprimer de la corbeille.
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.
Composante : wd240ggl.dll
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire