PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
SFDéconnecte (Fonction)
En anglais : SFDisconnect
Déconnecte :
  • la plateforme Salesforce.
  • la session Salesforce en cours.
  • les sessions Salesforce spécifiées.
Versions 20 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
Nouveauté 20
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
Versions 24 et supérieures
Linux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
Linux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Linux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
...
// Déconnexion (première syntaxe)
SI PAS SFDéconnecte(Cnx) ALORS
Erreur("La déconnexion a échoué")
FIN
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
        Erreur("La connexion a échoué")
        RETOUR
FIN
...
// Déconnexion (deuxième syntaxe)
MesSessions est un tableau de chaînes
Ajoute(MesSessions, Cnx..InfoSession..IdSession)
MonRésultat est un tableau de sfRésultatDéconnecte
SI SFDéconnecte(Cnx, MesSessions, MonRésultat) = Faux ALORS
         Erreur("Une déconnexion a échoué")
         Trace(MonRésultat[1]..Succès) // Affiche 0
FIN
Syntaxe

Déconnecter la plateforme Salesforce Masquer les détails

<Résultat> = SFDéconnecte(<Connexion Salesforce>)
<Résultat> : Booléen
  • Vrai si la déconnexion a été effectuée,
  • Faux dans le cas contraire.
Si la session a été déjà déconnectée ou si il n'y a pas eu de connexion, <Résultat> vaut Vrai.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.

Déconnecter une ou plusieurs sessions Masquer les détails

<Résultat> = SFDéconnecte(<Connexion Salesforce> , <Identifiant de session> [, <Compte-rendu>])
<Résultat> : Booléen
  • Vrai si les déconnexions ont été effectuées,
  • Faux dans le cas contraire (par exemple si une des déconnexions n'a pas pu s'effectuer).
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Identifiant de session> : Variable de type Tableau
Tableau de chaînes contenant les identifiants des sessions à fermer.
<Compte-rendu> : Variable optionnelle de type tableau
Tableau de variables de type sfRésultatDéconnecte. Ce tableau contient après l'exécution de la fonction le compte-rendu de chaque déconnexion.
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
  • Une des déconnexions n'a pas pu s'effectuer.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.
Composante : wd240ggl.dll
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire