PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemple
  • Affectation d'un membre de la classe courante
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 4 : Il faut un espace après le caractère ':'
Cause
Cette ligne de code permet par exemple d'affecter ou d'accéder à un membre d'une classe dans une boucle de type SELON. Le caractère ':' est utilisé successivement pour :
  • désigner la condition (CAS : ),
  • désigner le membre de la classe.
Correction
Insérez le caractère espace entre les deux "deux points".
Exemple

Affectation d'un membre de la classe courante

Code provoquant l'erreur
SELON NbRep
        CAS 1 : i=1
        CAS 2 : i=2
        CAS 5 ::b=4
FIN
Correction proposée
Insérer un espace entre les caractères : :.
SELON NbRep
        CAS 1 : i=1
        CAS 2 : i=2
        CAS 5 : : b=4
FIN
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire