DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Mise à jour d'une base connectée
SQLModifie (Exemple)
Exemple : Mise à jour d'une base connectée
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsCode Utilisateur (MCU)AjaxHyper File 5.5OLE DBODBC Cet exemple est une procédure permettant de mettre à jour une base connectée.
// Procédure de mise à jour de la base connectée
PROCÉDURE  ModifClient()
Res est un booléen
RequêteU, Requête est une chaîne
Res = SQLExec("SELECT NUMCLI, CODEPOSTAL, VILLE FROM CLIENT", "REQSELECT")
SI Res = Faux ALORS
// Traitement de l'erreur
FIN
SQLAssocie("REQSELECT", NumClient, CodePostal, Ville)
// Mise à jour de tous les clients
SQLPremier("REQSELECT")
TANTQUE PAS SQL.EnDehors
SI Ville = "MONTPELLIER" ALORS
// Exécution d'une requête de modification sur la base
  RequêteU = "UPDATE CLIENT SET CODEPOSTAL='34000'" + ...
 "WHERE NUMCLI=" + NumClient
  // Exécution de la requête
  SQLExec(RequêteU, "REQUPDATE")
  // Mise à jour de la table associée
  SQLInfoGene("REQSELECT")
  // Modification identique sur le résultat
  // pour ne pas ré-exécuter la requête de sélection
  Requête = NumClient + TAB + "34000" + TAB + Ville
  SQLModifie("REQSELECT", SQL.EnCours, Requête)
  FIN
SQLSuivant("REQSELECT")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire