PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemples
  • Utilisation d'un POUR sans FIN
  • Instructions imbriquées : une instruction POUR et une instruction SI sont imbriquées
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 22 : Il manque le fin associé à ce POUR
Cause
Vous avez utilisé une instruction répétitive de type POUR. Cette instruction doit se terminer par le mot-clé FIN.
Correction
Vérifiez le code de votre instruction répétitive et ajoutez si nécessaire le mot-clé FIN manquant.
Exemples

Utilisation d'un POUR sans FIN

Code provoquant l'erreur
POUR I = 1 A 10
        MonTableau[I] = MaVariable + 10
Correction proposée
Ajoutez le mot-clé FIN à la fin de la répétition.
POUR I = 1 A 10
        MonTableau[I] = MaVariable + 10
FIN

Instructions imbriquées : une instruction POUR et une instruction SI sont imbriquées

Code provoquant l'erreur
POUR I = 1 A TABLE_TABLE1..Occurrence
        SI COL_LOGICIEL[I] = "WEBDEV" ALORS
                TABLE_TABLE1[I][2]..CouleurFond = BleuClair
                TABLE_TABLE1[I][2]..Couleur = iJauneClair
FIN
Correction proposée
Vérifiez que toutes les instructions imbriquées se terminent correctement (par l'instruction FIN par exemple). Dans notre exemple, l'instruction SI n'a pas de FIN associée. Ajoutez une instruction FIN.
POUR I = 1 A TABLE_TABLE1..Occurrence
        SI COL_LOGICIEL[I] = "WEBDEV" ALORS
                TABLE_TABLE1[I][2]..CouleurFond = BleuClair
                TABLE_TABLE1[I][2]..Couleur = iJauneClair
        FIN
FIN
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire