PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemples
  • Utilisation d'un entier dans le compteur de la boucle et d'un réel dans le PAS de la boucle
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 20 : La variable de la boucle POUR devrait être réelle
Cause
Vous utilisez une instruction répétitive de type POUR. Dans cette instruction, vous utilisez une variable entière pour le compteur de la boucle et une valeur réelle pour la valeur du PAS.
Correction
Harmonisez les types utilisés dans le compteur de la boucle et dans le PAS de la boucle. Le même type doit être utilisé.
Exemples

Utilisation d'un entier dans le compteur de la boucle et d'un réel dans le PAS de la boucle

Code provoquant l'erreur
I est un entier
POUR I=1 A 10 PAS 0.4
        SI COL_Logiciel[I]=2 ALORS
                TABLE_TABLE1[I][2]..CouleurFond = BleuClair
        FIN
FIN
Correction proposée
Utilisez le type entier pour le PAS.
Dans cet exemple, la répétition ne se fera pas : le calcul effectué pour la première valeur de la boucle sera : 1 + 0,4 = 1,4. La valeur 1,4 est arrondie à 1. La boucle reste toujours à 1.
I est un entier
POUR I=1 A 10 PAS 1
        SI COL_Logiciel[I]=2 ALORS
                TABLE_TABLE[I][2]..CouleurFond = BleuClair
        FIN
FIN
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire