PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemple
  • L'instruction AUTRES CAS n'est pas la dernière instruction
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 17 : AUTRES CAS doit être en dernier dans le SELON
Cause
Vous utilisez une instruction conditionnelle de type SELON ... CAS. L'instruction "AUTRES CAS" doit être le dernier CAS utilisé.
Correction
Déplacez le bloc d'instructions commençant par "AUTRES CAS" à la fin de l'instruction conditionnelle SELON.
Exemple

L'instruction AUTRES CAS n'est pas la dernière instruction

Code provoquant l'erreur
SELON TypeProduit
        CAS "1"
            Message("Produit alimentaire")
        AUTRES CAS
            Message("Promotion exceptionnelle")
        CAS "2"
            Message("Produit de nettoyage")
FIN


Correction proposée
Déplacez le bloc d'instructions commençant par "AUTRES CAS" à la fin de l'instruction conditionnelle SELON.
SELON TypeProduit
        CAS "1"
            Message("Produit alimentaire")
        CAS "2"
            Message("Produit de nettoyage")
        AUTRES CAS
            Message("Promotion exceptionnelle")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire