PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemple
  • Le début de l'instruction conditionnelle n'a pas été saisie
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 14 : Instruction SINON sans SI
Cause
Vous avez utilisé le mot-clé SINON sans utiliser l'instruction conditionnelle SI correspondante.
Correction
Vérifiez le code de votre instruction conditionnelle.
Exemple

Le début de l'instruction conditionnelle n'a pas été saisie

Code provoquant l'erreur
SAI_Cours = "Français"
SINON
        SAI_Cours = "Anglais"
FIN
Corrections proposées
Complétez l'instruction conditionnelle.
SI TableSelect(TABLE_Cours) = 1 ALORS
SAI_Cours = "Français"
SINON
SAI_Cours = "Anglais"
FIN
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire