PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemples
  • Utilisation de deux mots-clés du WLangage incompatibles
  • Expression de calcul incorrecte
  • Utilisation d'un mot-clé sans respecter sa syntaxe : SELON sans condition par exemple
  • Utilisation d'une syntaxe incorrecte pour les fonctions
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 1 : Erreur de syntaxe
Cause
Dans la ligne de code en cours, une erreur de syntaxe a été détectée. Les causes de cette erreur peuvent être :
  • Un mot-clé du WLangage a été utilisé de façon anormale.
  • Un symbole du WLangage (parenthèse, ...) a été utilisé de façon anormale.
Correction
Vérifiez et corrigez la syntaxe de la ligne en cours.
Exemples

Utilisation de deux mots-clés du WLangage incompatibles

Code provoquant l'erreur
POUR TANTQUE MaVariable > 10
        Tableau1[MaVariable] = MaVariable+10
FIN
Correction proposée
Utilisez le mot-clé approprié.
TANTQUE MaVariable > 10
        Tableau1[MaVariable] = MaVariable+10
FIN

Expression de calcul incorrecte

Code provoquant l'erreur
Utilisez le mot-clé approprié.
MaVariable = 10 ** 3
Correction proposée
Supprimez le second signe " * ".
MaVariable = 10 * 3

Utilisation d'un mot-clé sans respecter sa syntaxe : SELON sans condition par exemple

Code provoquant l'erreur
SELON
CAS 2 : ErreurTexte = "Le nom du client n'est pas saisi"
CAS 3 : ErreurTexte = "Le numéro de téléphone du client est incomplet"
FIN
Correction proposée
Précisez la condition.
SELON CodeErreur
CAS 2 : ErreurTexte = "Le nom du client n'est pas saisi"
CAS 3 : ErreurTexte = "Le numéro de téléphone du client est incomplet"
FIN

Utilisation d'une syntaxe incorrecte pour les fonctions

Code provoquant l'erreur
HLitPremier)Client, Nom)
Correction proposée
Remplacez la parenthèse fermante par une parenthèse ouvrante.
HLitPremier(Client, Nom)
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire