PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Syntaxe 1 : Parcours des éléments du tableau
  • Syntaxe 2 : Parcours des valeurs des éléments du tableau
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
L'instruction POUR TOUT permet d'effectuer différents types de parcours de tableaux :
  • Parcours des éléments du tableau,
  • Parcours des valeurs des éléments du tableau.
Remarque : Les instructions POUR TOUT, POUR TOUS, POUR CHAQUE sont acceptées. Dans cette documentation, seule l'instruction POUR TOUT est utilisée et peut être remplacée par POUR TOUS ou POUR CHAQUE.
Versions 15 et supérieures
L'instruction POUR TOUT peut également être utilisée pour parcourir les objets DotNet qui implémentent l'interface IEnumerable.
Nouveauté 15
L'instruction POUR TOUT peut également être utilisée pour parcourir les objets DotNet qui implémentent l'interface IEnumerable.
L'instruction POUR TOUT peut également être utilisée pour parcourir les objets DotNet qui implémentent l'interface IEnumerable.
Versions 17 et supérieures
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Nouveauté 17
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WEBDEV - Code Navigateur Cette fonctionnalité est disponible en code navigateur.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Nouveauté 18
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WEBDEV - Code Navigateur Cette fonctionnalité est disponible en code navigateur.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WEBDEV - Code Navigateur Cette fonctionnalité est disponible en code navigateur.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Versions 21 et supérieures
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Nouveauté 21
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Exemple
// Parcourir les éléments d'un tableau de réels pour en calculer la somme
// Remplissage du tableau
tabCalcul est un tableau de 3 réels
tabCalcul[1] = 12.5
tabCalcul[2] = 10
tabCalcul[3] = 7.5
// Calcul de la somme
SommeTotal est un réel
POUR TOUT UnElément DE tabCalcul
        SommeTotal += UnElément
FIN
Versions 20 et supérieures
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile
// Parcourir le tableau tabClients des clients en traitant que les clients
// dont la ville est égal à "MONTPELLIER".

stClient est une Structure
Nom est une chaîne
Prénom est une chaîne
Ville est une chaîne
FIN

tabClients est un tableau de stClient

POUR TOUT stUnClient DE tabClients AVEC Ville = "MONTPELLIER"
// Traitement
FIN
Nouveauté 20
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile
// Parcourir le tableau tabClients des clients en traitant que les clients
// dont la ville est égal à "MONTPELLIER".

stClient est une Structure
Nom est une chaîne
Prénom est une chaîne
Ville est une chaîne
FIN

tabClients est un tableau de stClient

POUR TOUT stUnClient DE tabClients AVEC Ville = "MONTPELLIER"
// Traitement
FIN
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile
// Parcourir le tableau tabClients des clients en traitant que les clients
// dont la ville est égal à "MONTPELLIER".

stClient est une Structure
Nom est une chaîne
Prénom est une chaîne
Ville est une chaîne
FIN

tabClients est un tableau de stClient

POUR TOUT stUnClient DE tabClients AVEC Ville = "MONTPELLIER"
// Traitement
FIN
Syntaxe

Parcours des éléments du tableau Masquer les détails

POUR TOUT [ELEMENT] <Variable> [, <Clé> [, <Compteur>]] DE <Tableau> [AVEC <Condition>] [<Sens>]
    ...
FIN
<POUR TOUT [ELEMENT]> :
Signale le début du bloc d'instructions. Le mot-clé ELEMENT est optionnel.
<Variable> :
Variable exactement du même type que les éléments du tableau. Pour des tableaux de classe, la variable doit être de type Classe dynamique. Il n'est pas nécessaire de déclarer cette variable.
<Clé> :
Clé de l'élément parcouru. Cette clé dépend de l'élément parcouru :
  • Tableau à une dimension : indice de l'élément dans le tableau.
  • Tableau à deux dimensions ou plus : compteur qui commence à 1
Il n'est pas nécessaire de déclarer cette variable.
<Compteur> :
Variable de type entier contenant le nombre d'itérations. Il n'est pas nécessaire de déclarer cette variable.
<Tableau> :
Tableau à parcourir.
<Condition> :
Versions 20 et supérieures
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile Condition à indiquer pour filtrer le parcours. Seuls les éléments du tableau correspondant au filtre seront parcourus.
Nouveauté 20
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile Condition à indiquer pour filtrer le parcours. Seuls les éléments du tableau correspondant au filtre seront parcourus.
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile Condition à indiquer pour filtrer le parcours. Seuls les éléments du tableau correspondant au filtre seront parcourus.
<Sens> :
Indicateur optionnel du sens de parcours :
DepuisDébut
(valeur par défaut)
Parcours le tableau du premier élément au dernier.
DepuisFinParcours le tableau du dernier élément au premier.

Parcours des valeurs des éléments du tableau Masquer les détails

POUR TOUT [ELEMENT] <Valeur> DE <Tableau> [AVEC <Condition>] [<Sens>]
    ...
FIN
<POUR TOUT ELEMENT> :
Signale le début du bloc d'instructions. Le mot-clé ELEMENT est optionnel.
<Valeur> :
Variable d'un type compatible avec les éléments du tableau. Il n'est pas nécessaire de déclarer cette variable.
<Tableau> :
Tableau à parcourir.
<Condition> :
Versions 20 et supérieures
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile Condition à indiquer pour filtrer le parcours. Seuls les éléments du tableau correspondant au filtre seront parcourus.
Nouveauté 20
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile Condition à indiquer pour filtrer le parcours. Seuls les éléments du tableau correspondant au filtre seront parcourus.
WINDEVWEBDEV - Code ServeuriPhone/iPadApple WatchWindows Mobile Condition à indiquer pour filtrer le parcours. Seuls les éléments du tableau correspondant au filtre seront parcourus.
<Sens> :
Indicateur optionnel du sens de parcours :
DepuisDébut
(valeur par défaut)
Parcours le tableau du premier élément au dernier.
DepuisFinParcours le tableau du dernier élément au premier.
Remarques

Syntaxe 1 : Parcours des éléments du tableau

A chaque itération, la variable <Variable> fait directement référence à l'élément courant dans le tableau. Si la valeur de <Variable> est modifiée, l'élément courant dans le tableau est modifié.
En sortie de boucle (Fin normale ou instruction SORTIR), la valeur de <Variable> est affectée avec celle du dernier élément parcouru, mais <Variable> ne fait plus directement référence à l'élément dans le tableau.
Tous les types de tableaux sont disponibles : automatiques, fixes, dynamiques.
Les tableaux peuvent avoir plusieurs dimensions.
Le comportement est indéterminé si le nombre d'éléments est modifié dans la boucle de parcours.

Syntaxe 2 : Parcours des valeurs des éléments du tableau

A chaque itération, la variable <Valeur> est affectée avec la valeur de l'élément parcouru. Si la valeur de <Valeur> est modifiée, l'élément courant dans le tableau n'est pas modifié.
Tous les types de tableaux sont disponibles : automatiques, fixes, dynamiques.
Les tableaux peuvent avoir plusieurs dimensions.
Le comportement est indéterminé si le nombre d'éléments est modifié dans la boucle de parcours.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire