PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Fonctionnement
  • Cas particulier
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
L'étiquette FIN : permet de définir un code qui sera exécuté systématiquement à la fin de l'exécution d'un traitement. Ce code sera exécuté même si la sortie du traitement est réalisée avec le mot-clé RETOUR ou le mot-clé RENVOYER (sauf dans le cas d'un traitement d'exception provoqué par la fonction ExceptionDéclenche).
Versions 16 et supérieures
Universal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
Nouveauté 16
Universal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
Universal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
Versions 17 et supérieures
iPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Universal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Nouveauté 18
Universal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Universal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Versions 21 et supérieures
Universal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Apple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Nouveauté 21
Universal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Apple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Universal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Apple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Exemple
PROCEDURE CompareContenu(Fic1, Fic2)

// Ouvre les fichiers
nFic1 est un entier = fOuvre(Fic1, foLecture)
nFic2 est un entier = fOuvre(Fic2, foLecture)

// En cas d'erreur d'ouverture, renvoie -3
SI nFic1 = -1 OU nFic2 = -1 ALORS RENVOYER -3

// Lit la première ligne de chaque fichier
sLigne1 est une chaîne = fLitLigne(nFic1)
sLigne2 est une chaîne = fLitLigne(nFic2)
nLigne est un entier = 1

BOUCLE
// Si les deux lignes sont vides, c'est la fin des deux fichiers
// Renvoie 0
SI sLigne1 = EOT _ET_ sLigne2 = EOT ALORS RENVOYER 0

// Si fin du fichier 1, le fichier 1 est plus court
// renvoie -1
SI sLigne1 = EOT ALORS RENVOYER -1

// Si fin du fichier 2, le fichier 2 est plus court
// renvoie -2
SI sLigne2 = EOT ALORS RENVOYER - 2

// Si les lignes sont différentes, renvoie le numéro de la ligne différente
SI sLigne1 <> sLigne2 ALORS RENVOYER nLigne

// Passe à la ligne suivante
sLigne1 = fLitLigne(nFic1)
sLigne2 = fLitLigne(nFic2)
nLigne++
FIN

FIN:
// Ferme les fichiers
fFerme(nFic1)
fFerme(nFic2)
Syntaxe
// Code principal
...
SI ...ALORS
  ...
  RENVOYER 0
FIN
...
SI ...ALORS
  ...
  RENVOYER 1
FIN

RENVOYER 2

// Instructions exécutées dans tous les cas
// en fin d'exécution du traitement
FIN :
...
Remarques

Fonctionnement

La valeur à renvoyer est mémorisée, puis le code suivant l'étiquette "FIN:" est exécuté. La valeur est renvoyée réellement à la fin de l'exécution du code suivant l'instruction "FIN:"
Remarque : L'étiquette FIN: est également exécutée après la gestion automatique des erreurs si celle-ci est activée (avec les mots-clé "CAS ERREUR:" et "CAS EXCEPTION:").

Cas particulier

Après un appel à la fonction RepriseSaisie ou à la fonction Ferme, le code suivant l'étiquette "FIN:" n'est pas exécuté. La fonction RepriseSaisie peut être remplacée par l'appel à la fonction EcranPremier suivie de RETOUR ou RENVOYER.
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire