PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Code à exécuter
  • Sortir d'une boucle de type TANTQUE
  • Boucle sans fin
  • Exécution de l'itération suivante
  • Condition composée
Produits
WINDEVWEBDEV - Code ServeurWEBDEV - Code NavigateurWINDEV MobileEtats et Requêtes
Plateformes
WindowsLinuxWindows MobileUniversal Windows 10 AppAndroidWidget AndroidiPhone/iPadApple Watch
Langages
JavaPHPAjaxCode Utilisateur (MCU)Langage Externe
Bases de données
HFSQLHFSQL Client/ServeurProcédures stockéesOLE DBODBCAccès Natifs
Dans une instruction TANTQUE, l'expression est évaluée à chaque début du bloc d'instructions.
Tant que l'expression de condition est vraie, le traitement boucle. Il y a sortie du bloc d'instructions lorsque l'expression de condition est fausse.
Versions 16 et supérieures
WINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
Nouveauté 16
WINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
WINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
Versions 17 et supérieures
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Nouveauté 17
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Nouveauté 18
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Versions 21 et supérieures
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Nouveauté 21
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Exemple
MaListe = INILit("Exemples", "", "", FichierINI)
MotClé = ExtraitChaîne(MaListe, nb, RC)
TANTQUE MotClé <> ""
        nb = nb + 1
        NomExpl = INILit("Projets installés", MotClé, "", FichierINI)
        MotClé = ExtraitChaîne(MaListe, nb + 1, RC)
FIN
Syntaxe

Condition "TANTQUE" Masquer les détails

TANTQUE <Condition>
  <Action si condition vraie>
FIN
<TANTQUE> :
Signale le début du bloc d'instructions.
<Condition> :
Condition à tester.
<Action si condition vraie> :
Action à lancer si la condition est vraie.
<FIN> :
Signale la fin du bloc d'instructions.

Boucle avec sortie selon une condition "TANTQUE" Masquer les détails

BOUCLE
  ...
  A FAIRE TANTQUE <Condition>
<BOUCLE> :
Signale le début du bloc d'instructions.
<A FAIRE TANTQUE> :
Signale la fin du bloc d'instructions. Permet de quitter le bloc d'instructions. Les lignes de la boucle situées avant cette instruction sont exécutées.
Remarques

Code à exécuter

Le code à exécuter est placé entre les instructions TANTQUE et FIN.

Sortir d'une boucle de type TANTQUE

Plusieurs instructions sont possibles :
  • RETOUR : Sortie de la boucle TANTQUE et sortie du traitement (ou de la procédure) en cours.
  • RENVOYER : Renvoi d'un compte-rendu au traitement appelant. Sortie de la boucle TANTQUE et sortie du traitement (ou de la procédure) en cours.
  • SORTIR : Sortie de la boucle TANTQUE et exécution de la suite du traitement en cours.
La fonction Ferme permet de sortir de la boucle TANTQUE et de fermer la fenêtre en cours.
Attention : Il n'est pas possible d'utiliser les instructions RETOUR et RENVOYER dans un même traitement.

Boucle sans fin

Lors de la compilation du projet, une instruction TANTQUE sans fin évidente (absence des instructions SORTIR, RETOUR ou RENVOYER) est signalée par un warning.

Exécution de l'itération suivante

Pour exécuter directement l'itération suivante sans terminer le code de l'itération en cours, utilisez l'instruction CONTINUER :
TANTQUE <Condition>
...
SI <Condition> ALORS CONTINUER  // Retour au mot-clé TANTQUE
...
FIN

Condition composée

Les mots-clés ET et OU permettent d'effectuer des opérations logiques et de construire des conditions composées.
Par exemple :
TANTQUE Prix < 100 ET TypeProduit = "AA"
        NbreProduit ++          // Nombre de produits dont le prix est inférieur
                                                         // à 100 € et dont le type est "AA"
FIN

TANTQUE Prix > 100 OU Prix < 500
         NbreProduit ++         // Nombre de produits dont le prix est compris entre 100 et 500 €
FIN
Les conditions composées de ET et OU sont évaluées dans leur totalité.
Par exemple :
A1 > 10 ET B1 < 20
Si la première condition (A1 > 10) est fausse, la deuxième condition (B1 < 20) sera tout de même vérifiée.
Optimiser l'évaluation des conditions composées : Utilisez les mots-clés _ET_ et _OU_. Si la première condition est fausse (A1 > 10 dans notre exemple), la seconde condition (B1 < 20 dans notre exemple) ne sera pas testée.
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire