PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Code à exécuter
  • Sortir d'une boucle
  • Exécution de l'itération suivante
  • Boucle sans fin
  • Variable externe dans une boucle
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le bloc d'instructions est répété à l'infini. Le nombre d'itérations du bloc d'instructions n'est pas contrôlé, il n'y a pas d'expression à évaluer.
Versions 16 et supérieures
WINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
Nouveauté 16
WINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
WINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible pour les applications Windows Phone.
Versions 17 et supérieures
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Nouveauté 17
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
WINDEV MobileiPhone/iPad Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Nouveauté 18
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Windows Store apps.
WINDEV MobileWidget Android Cette fonctionnalité est disponible en mode Widget Android.
Versions 21 et supérieures
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Nouveauté 21
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
WINDEVWINDEV MobileUniversal Windows 10 App Cette fonctionnalité est disponible en mode Universal Windows 10 App.
WINDEV MobileApple Watch Cette fonctionnalité est disponible en mode Apple Watch.
Exemple
// Sortie selon une condition SI
BOUCLE
       // Lecture d'une ligne du fichier texte
        UneLigne = fLitLigne(NumFic)
        SI UneLigne = EOT ALORS SORTIR
        TraiteLigne(UneLigne)
FIN
// Sortie selon une condition TANTQUE
BOUCLE
       // Lecture d'une ligne du fichier texte
        UneLigne = fLitLigne(NumFic)
        TraiteLigne(UneLigne)
A FAIRE TANTQUE UneLigne <> EOT
// Sortie selon une itération
BOUCLE (10)
       // Lecture d'une ligne du fichier texte
        UneLigne = fLitLigne(NumFic)
        TraiteLigne(UneLigne)
FIN
Syntaxe

Boucle avec sortie selon une condition "SI" Masquer les détails

BOUCLE
   ...
   SI <Condition> ALORS SORTIR
   ...
FIN
<BOUCLE> :
Signale le début du bloc d'instructions.
<SORTIR> :
Permet de quitter le bloc d'instructions.
<FIN> :
Signale la fin du bloc d'instructions.

Boucle avec sortie selon une condition "TANTQUE" Masquer les détails

BOUCLE
...
A FAIRE TANTQUE <Condition>
<BOUCLE> :
Signale le début du bloc d'instructions.
<A FAIRE TANTQUE> :
Signale la fin du bloc d'instructions. Permet de quitter le bloc d'instructions. Les lignes de la boucle situées avant cette instruction sont exécutées.

Boucle avec sortie selon le nombre d'itérations Masquer les détails

BOUCLE (<Nombre d'itérations>)
...
FIN
<BOUCLE> :
Signale le début du bloc d'instructions.
<Nombre d'itérations> :
Nombre d'itérations à exécuter. La sortie de la boucle se fera lorsque le nombre d'itérations sera atteint.
<FIN> :
Signale la fin du bloc d'instructions.
Remarques

Code à exécuter

Le code à exécuter est placé entre les instructions BOUCLE et FIN.

Sortir d'une boucle

Plusieurs instructions sont possibles :
  • RETOUR : Sortie de la boucle et sortie du traitement (ou de la procédure) en cours.
  • RENVOYER : Renvoi d'un compte-rendu au traitement appelant. Sortie de la boucle et sortie du traitement (ou de la procédure) en cours.
  • SORTIR : Sortie de la boucle et exécution de la suite du traitement en cours.
La fonction Ferme permet de sortir de la boucle et de fermer la fenêtre en cours.
Attention : Il n'est pas possible d'utiliser les instructions RETOUR et RENVOYER dans un même traitement.

Exécution de l'itération suivante

Pour exécuter directement l'itération suivante sans terminer le code de l'itération en cours, utilisez l'instruction CONTINUER :
BOUCLE
...
SI <Condition> ALORS CONTINUER // Retour au mot-clé BOUCLE
...
FIN

Boucle sans fin

Lors de la compilation du projet, une boucle sans fin évidente (absence des instructions SORTIR, RETOUR ou RENVOYER) est signalée par un warning.

Variable externe dans une boucle

Une variable déclarée avec le mot-clé EXTERNE ne peut pas être utilisée dans une boucle.
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire