PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation
  • Comment manipuler une base de données avec Hive en programmation ?
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
Hive est une couche logicielle de Hadoop permettant d’exécuter des requêtes.
Hive utilise le langage HiveQL qui est un langage proche du SQL.
Le développeur spécifie sa requête en utilisant le HiveQL (une syntaxe dérivée du SQL) et le moteur Hive traduit cette requête pour interroger nativement la base de données HBase.
En version 21, il est possible d’exécuter des requêtes HiveQL en utilisant la famille de fonctions SQL du WLangage.
Comment manipuler une base de données avec Hive en programmation ?
Pour manipuler une base de données avec Hive, il faut utiliser les fonctions SQL du WLangage.
Il est ainsi possible de :
  • Se connecter à la base de données (fonction SQLConnecte ou SQLConnecteWS).
  • Récupérer des données (fonction SQLExec). Pour plus de détails sur la syntaxe des requêtes HiveQL, consultez la documentation HiveQL.
  • Se déconnecter de la base de données (fonction SQLDéconnecte).
Exemple :
NumConnexion est un entier
NumConnexion = SQLConnecte("master2.hadoop1.monserveur.com", "sa", "", "default", "HIVE")
SI NumConnexion <> 0 ALORS
// La connexion s'est bien passée
// Utilisation de la connexion pour exécuter des requêtes SQL
SI SQLExec("SELECT * FROM EQUIPE WHERE NOM='HOU'") = Vrai ALORS
// Traitement de la requête
SINON
// Échec de la requête : affichage d'un message explicatif
SQLInfoGene("RECHCLIENTPARNOM")
Erreur("Erreur" + SQL.Erreur + "dans la requête : ", SQL.MesErreur)
FIN
SINON
// La connexion a échoué : affichage d'un message explicatif
SQLInfoGene()
Erreur("La connexion à la source de données a échoué." + RC + ...
"Code erreur : " + SQL.Erreur + RC + SQL.MesErreur)
FIN
// Dans tous les cas (connexion OK ou pas)
SQLDéconnecte()

Attention : L'accès aux bases de données en HiveQL est disponible en exécution uniquement à partir de Windows Vista ou Windows Server 2008.
Version minimum requise
  • Version 21
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire