PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Produits
WINDEVWEBDEV - Code ServeurWEBDEV - Code NavigateurWINDEV MobileEtats et Requêtes
Plateformes
WindowsLinuxWindows MobileUniversal Windows 10 AppAndroidWidget AndroidiPhone/iPadApple Watch
Langages
JavaPHPAjaxCode Utilisateur (MCU)Langage Externe
Bases de données
HFSQLHFSQL Client/ServeurProcédures stockéesOLE DBODBCAccès Natifs
La propriété ..Cumul permet de savoir si la valeur d'une colonne ou d'une ligne d'un champ Tableau croisé dynamique correspond à un total (total de fin de ligne ou de fin de colonne). Cette propriété peut être utilisée uniquement dans le traitement d'affichage d'une cellule.
Exemple
// Code d’affichage d'une cellule d'un tableau croisé dynamique

SI COL_DateCommande_Année..Cumul = Vrai OU COL_Pays..Cumul = Vrai ALORS
polPolice est une Police
// On est sur une ligne/colonne de total
polPolice..Nom = "Trebuchet MS"
polPolice..Taille = 8
polPolice..Couleur = Noir
polPolice..Gras = Vrai
polPolice..Italique = Vrai

// Change la couleur de fond des totaux
VAL_CA..CouleurFond = JauneBulle
VAL_Qté..CouleurFond = JauneBulle

// Change la police
VAL_CA..Police = polPolice
VAL_Qté..Police = polPolice
SINON
SI VAL_CA <= 500 _ET_ VAL_CA > 0 ALORS
VAL_CA..CouleurFond = RougePastel
FIN
SI VAL_CA >= 30000  ALORS
VAL_CA..CouleurFond = VertPastel
FIN
FIN
Syntaxe
<Résultat> = <En-tête de ligne ou de colonne>..Cumul
<Résultat> : Booléen
  • Vrai si la colonne ou la ligne correspond à un total,
  • Faux dans le cas contraire.
<En-tête de ligne ou de colonne> : Chaîne de caractères (avec ou sans guillemets)
En-tête de ligne ou de colonne d’un champ Tableau croisé dynamique.
Remarques
Il est également possible de savoir si la valeur d'une colonne ou d'une ligne d'un champ Tableau croisé dynamique correspond à un total en testant la valeur de la colonne ou de la ligne.
Pour un total :
  • la valeur de la colonne ou de la ligne correspond à "*".
  • la propriété ..Cumul vaut Vrai.
// Code d’affichage d'une cellule d'un tableau croisé dynamique

SI COL_DateCommande_Année = "*" OU COL_Pays..Cumul = "*" ALORS
polPolice est une Police
// On est sur une ligne/colonne de total
polPolice..Nom = "Trebuchet MS"
polPolice..Taille = 8
polPolice..Couleur = Noir
polPolice..Gras = Vrai
polPolice..Italique = Vrai

// Change la couleur de fond des totaux
VAL_CA..CouleurFond = JauneBulle
VAL_Qté..CouleurFond = JauneBulle

// Change la police
VAL_CA..Police = polPolice
VAL_Qté..Police = polPolice
SINON
SI VAL_CA <= 500 _ET_ VAL_CA > 0 ALORS
VAL_CA..CouleurFond = RougePastel
FIN
SI VAL_CA >= 30000  ALORS
VAL_CA..CouleurFond = VertPastel
FIN
FIN
Liste des exemples associés :
WD TableauCroiséDynamique Exemples didactiques (WINDEV) : WD TableauCroiséDynamique
[ + ] Cet exemple illustre l'utilisation du champ Tableau croisé dynamique.

Ce champ tableau croisé dynamique permet d'afficher des statistiques dynamiques en effectuant des regroupements.
Ces statistiques sont calculées à partir de la base de données.
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire