PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Produits
WINDEVWEBDEV - Code ServeurWEBDEV - Code NavigateurWINDEV MobileEtats et Requêtes
Plateformes
WindowsLinuxWindows MobileUniversal Windows 10 AppAndroidWidget AndroidiPhone/iPadApple Watch
Langages
JavaPHPAjaxCode Utilisateur (MCU)Langage Externe
Bases de données
HFSQLHFSQL Client/ServeurProcédures stockéesOLE DBODBCAccès Natifs
La propriété ..AvecSaisie permet de savoir si un champ Combo est avec ou sans saisie et permet de modifier cet état.
Exemple
SI bModeExpert = Vrai ALORS
        COMBO_AdresseInternet..AvecSaisie = Vrai
FIN

SI COMBO_AdresseInternet..AvecSaisie = Vrai ALORS
        sAdresseNet = COMBO_AdresseInternet
SINON
        sAdresseNet = COMBO_AdresseInternet[COMBO_AdresseInternet]
FIN
Syntaxe

Savoir si un champ Combo est avec saisie ou non Masquer les détails

<Résultat> = <Nom du champ>..AvecSaisie
<Résultat> : Booléen
  • Vrai si le champ Combo est un champ Combo avec saisie,
  • Faux dans le cas contraire.
<Nom du champ> : Chaîne de caractères (avec ou sans guillemets)
Nom du champ Combo à manipuler.

Permettre ou non de saisir dans un champ Combo Masquer les détails

<Nom du champ>..avecSaisie = <Type de saisie>
<Nom du champ> : Chaîne de caractères (avec ou sans guillemets)
Nom du champ Combo à manipuler.
<Type de saisie> : Booléen
  • Vrai si le champ Combo doit être avec saisie,
  • Faux dans le cas contraire.
Remarques
  • La valeur renvoyée par le champ Combo est différente si le champ est en saisie (propriété ..AvecSaisie égale à Vrai) ou sans saisie (propriété ..AvecSaisie égale à Faux).
  • Dans un champ Combo en saisie (propriété ..AvecSaisie égale à Vrai), l’utilisateur peut saisir une valeur dans le champ au clavier. Dans le cas contraire, l'utilisateur peut uniquement choisir une valeur dans la liste/table/popup déroulée par la combo.
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire