PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Permissions requises
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Exécutée sur le poste serveur, cette fonction permet d'attendre une demande de connexion provenant de sockets clients.
Remarques :
  • Si le poste client utilise une application WINDEV pour se connecter à ce socket, la demande de connexion est effectuée par la fonction SocketConnecte.
  • Socket de type UDP : La fonction SocketAttendConnexion ne peut pas être utilisée avec des sockets de type UDP.
WEBDEV - Code Serveur Pour utiliser les sockets sur le poste serveur, il est nécessaire de cocher l'option "Autoriser les sockets serveur" dans l'onglet "Avancé" de l'administrateur WEBDEV.
Versions 15 et supérieures
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 15
Android Cette fonction est désormais disponible pour les applications Android.
Android Cette fonction est désormais disponible pour les applications Android.
Rappel : Un socket est une ressource de communication utilisée par les applications pour communiquer d'une machine à une autre sans se soucier du type de réseau.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Versions 19 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 19
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 23 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 23
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobilePHPAjaxCode Utilisateur (MCU)
// Crée un socket sur le poste serveur
SI SocketCrée("Serveur", 8000) = Faux ALORS
Erreur("Erreur de création " + ErreurInfo(errMessage))
SINON
// Gestion des connexions des postes clients dans un thread
ThreadExécute("Thread1", threadNormal, ProcédureAttente)
FIN

//-----------------------------

PROCEDURE ProcédureAttente()
BOUCLE
//Windows finit les traitements en cours, rend la main à l'application WINDEV
// puis prend en compte les clics de souris et les actions sur les touches du clavier.
Multitâche(0)

SI SocketAttendConnexion("Serveur") ALORS
Canal est une chaîne
// Si la connexion est acceptée,
// la gestion de cette connexion est réalisée dans un thread spécifique
Canal = SocketAccepte("Serveur")
ThreadExécute(Canal, threadNormal, ProcédureGestion, Canal)
FIN
FIN
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobilePHPAjaxCode Utilisateur (MCU)
// Crée un socket sur le poste serveur
SI SocketCrée("Serveur", 8000) = Faux ALORS
Erreur("Erreur de création " + ErreurInfo(errMessage))
SINON
// Gestion des connexions des postes clients dans un thread
ThreadExécute("Thread1", threadNormal, ProcédureAttente)
FIN


PROCEDURE INTERNE ProcédureAttente()
BOUCLE
// Windows finit les traitements en cours, rend la main à l'application WINDEV
// puis prend en compte les clics de souris et les actions sur les touches du clavier.
Multitâche(0)

SI SocketAttendConnexion("Serveur") ALORS
Canal est une chaîne
// Si la connexion est acceptée,
// la gestion de cette connexion est réalisée dans un thread spécifique
Canal = SocketAccepte("Serveur")
ThreadExécute(Canal, threadNormal, ProcédureGestion, Canal)
FIN
FIN
FIN
Syntaxe
<Résultat> = SocketAttendConnexion(<Nom du socket> [, <Durée maximale>])
<Résultat> : Booléen
  • Vrai : une nouvelle demande de connexion est en attente.
  • Faux : aucune demande de connexion n'a été détectée.
<Nom du socket> : Chaîne de caractères (avec guillemets)
Nom du socket serveur qui attend la connexion.
WINDEV Attention : Le nom du socket est "case-sensitive".
<Durée maximale> : Entier optionnel ou Durée optionnelle
Durée d'attente maximale (en millisecondes).
  • Cette fonction est bloquante pendant la durée indiquée ou jusqu'à la détection d'une demande de connexion.
  • Si ce paramètre n'est pas précisé, la fonction est bloquante jusqu'à la prochaine tentative de connexion.
Remarque : si cette fonction est utilisée en multi-thread, la fonction ne bloque que le thread dans lequel elle est appelée.
Ce paramètre peut correspondre à :
  • un entier correspondant au nombre de millisecondes,
  • une variable de type Durée,
  • Versions 23 et supérieures
    l'indication directe de la durée (par exemple 1 s ou 10 ms).
    Nouveauté 23
    l'indication directe de la durée (par exemple 1 s ou 10 ms).
    l'indication directe de la durée (par exemple 1 s ou 10 ms).
Remarques
AndroidWidget Android

Permissions requises

L’utilisation de cette fonction entraîne la modification des permissions requises par l’application.
Permission requise : INTERNET
Cette permission autorise l’application à ouvrir des sockets réseau.
Composantes
WINDEVWEBDEV - Code ServeurEtats et Requêtes wd230com.dll
Windows Mobile wp230com.dll
Java wd230java.jar
Linux wd230com.so
Android wd230android.jar
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire