PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation
  • Mot de passe
Produits
WINDEVWEBDEV - Code ServeurWEBDEV - Code NavigateurWINDEV MobileEtats et Requêtes
Plateformes
WindowsLinuxWindows MobileUniversal Windows 10 AppAndroidWidget AndroidiPhone/iPadApple Watch
Langages
JavaPHPAjaxCode Utilisateur (MCU)Langage Externe
Bases de données
HFSQLHFSQL Client/ServeurProcédures stockéesOLE DBODBCAccès Natifs
Exécution de la requête et manipulation du résultat en WLangage
Présentation
La sélection d'enregistrements d'une requête n'est pas obligatoirement affichée dans un état, dans une fenêtre, ... Cette sélection peut également être utilisée en programmation.
La plupart des fonctions HFSQL (fonctions de parcours, de recherche, de lecture, ...) peuvent être utilisées aussi bien sur des fichiers de données que sur le résultat d'une requête. Pour utiliser ces fonctions sur une requête, il est nécessaire d'exécuter au préalable la requête (fonction HExécuteRequête).
Par exemple, la requête Client34 sélectionne les clients habitant dans le département de l'Hérault. La procédure ImprimeClient permet d'imprimer une facture prédéfinie pour chaque client. Le code suivant permet de parcourir le résultat de la requête Client34 et d'imprimer une facture pour l'ensemble des clients sélectionnés.
// Exécution de la requête
ResExécution = HExécuteRequête(Client34)
// Erreur lors de l'exécution de la requête ?
SI ResExécution = Vrai ALORS
// Parcours du résultat de la requête
POUR TOUT Client34
    // Impression de la facture pour chaque enregistrement
ImprimeClient(Client34.NomClient, Client34.PrénomClient, ...
Client34.AdresseClient, Client34.CodePostalClient, ...
Client34.VilleClient)
FIN
SINON
 // Affichage du message d'erreur
 Erreur("La requête n'a pas été exécutée.")
FIN
Remarque : A partir de la version 19, HFSQL est le nouveau nom de HyperFileSQL.
Mot de passe
  • Mot de passe de l'analyse : Si la requête est associée à une analyse protégée par un mot de passe en exécution, spécifiez ce mot de passe lors de l'ouverture de l'analyse (fonction HOuvreAnalyse) dans le traitement d'initialisation du projet.
  • Mot de passe du fichier : Si la requête est basée sur un (ou plusieurs) fichier(s) protégé(s) par un mot de passe, spécifiez ce(s) mot(s) de passe grâce à la fonction HPasse avant d'exécuter la requête (fonction HExécuteRequête).
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire