PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation
  • Exemple de récupération
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
L'analyse représente la structure des fichiers de données manipulés par le programme.
Il est possible par programmation de récupérer la structure de l'analyse afin de faire des contrôles ou de proposer une interface utilisateur pour interroger de manière générique une base de données.
Les fonctions nécessaires pour récupérer la structure d'une analyse sont :
Exemple de récupération
Cet exemple permet de récupérer la liste de tous les fichiers de l'analyse en cours. Pour chaque fichier listé, l'exemple récupère :
  • la liste des rubriques,
  • la liste des clés,
  • la liste des liaisons.
Code de l'exemple :
// Déclaration des variables
sListeFichier est une chaîne
sListeRubrique est une chaîne
sListeClé est une chaîne
sListeLiaison est une chaîne

// Chargement de la liste des fichiers de l'analyse
sListeFichier = HListeFichier()

// Parcours de la liste des fichiers de l'analyse
POUR TOUTE CHAÎNE sNomFichier DE sListeFichier SEPAREE PAR RC

// Chargement des rubriques du fichier
sListeRubrique = HListeRubrique(sNomFichier, hLstDétail)
// Chargement des clés du fichier
sListeClé = HListeClé(sNomFichier, hLstDétail)
// Chargement des liaisons du fichier
sListeLiaison = HListeLiaison(sNomFichier)


Trace("================ FICHIER ================")
Trace("Fichier : ", sNomFichier)
Trace("--- Liste des rubriques ---")
POUR TOUTE CHAÎNE sRubrique DE sListeRubrique SEPAREE PAR RC
Trace(sRubrique)
FIN
Trace("--- Liste des clés ---")
POUR TOUTE CHAÎNE sClé DE sListeClé SEPAREE PAR RC
Trace(sClé)
FIN
Trace("--- Liste des liaisons ---")
POUR TOUTE CHAÎNE sLiaison DE sListeLiaison SEPAREE PAR RC
Trace(sLiaison)
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire