PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Méthode 1 : Récupération directe de la liste des répertoires
  • Méthode 2 : utilisation d'une procédure pour traiter chaque répertoire
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Pour parcourir les répertoires d'un disque, il faut utiliser la fonction fListeRépertoire. Cette fonction permet de :
  • lister tous les répertoires et sous-répertoires d'un disque.
  • lister les répertoires d'un disque sans descendre dans les sous-répertoires.
  • lister les répertoires avec un filtre.
Deux méthodes de parcours sont disponibles :
Méthode 1 : Récupération directe de la liste des répertoires
Pour récupérer directement la liste des répertoires et les traiter :
  1. Récupérez dans une chaîne de caractères la liste de tous les répertoires en utilisant la fonction fListeRépertoire.
  2. Parcourez la chaîne récupérée dans une boucle. Chaque répertoire est séparé par un caractère RC.
  3. Traitez chaque répertoire trouvé.
Exemple de code :
sListeRépertoire est une chaîne
sRep est une chaîne

sListeRépertoire = fListeRépertoire("C:\Mes documents\")

POUR TOUTE CHAÎNE sRep DE sListeRépertoire SEPAREE PAR RC
// Traitement du répertoire sRep
// la variable sRep contient le nom du répertoire à traiter
FIN
Méthode 2 : utilisation d'une procédure pour traiter chaque répertoire
Pour traiter les répertoires listés via une procédure :
  1. Créez une procédure locale ou interne afin de traiter chaque répertoire trouvé.
  2. Parcourez la liste de tous les répertoires en utilisant la fonction fListeRépertoire avec la procédure précédemment créée.
Exemple de code :
PROCEDURE INTERNE pTraiteRep(sRepRacine, sRep)
// Traitement du répertoire trouvé
// La variable sRepRacine contient le répertoire racine
// La variable sRep contient le nom du dossier
Trace(sRepRacine, sRep)

FIN

// Parcours des répertoires
fListeRépertoire("C:\TEMP\", pTraiteRep)
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire