PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Présentation
  • Méthode 1 : Récupération directe de la liste des fichiers
  • Méthode 2 : Utilisation d'une procédure "Callback" pour traiter chaque fichier séparément
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
Pour parcourir les fichiers contenus dans un répertoire, il faut utiliser la fonction fListeFichier. Cette fonction permet de :
  • lister tous les fichiers d'un répertoire et de ses sous-répertoires.
  • lister les fichiers d'un répertoire sans descendre dans les sous-répertoires.
  • lister les fichiers avec un filtre (extension et/ou nom).
Deux méthodes sont disponibles :
Méthode 1 : Récupération directe de la liste des fichiers
Pour récupérer directement la liste des fichiers :
  1. Récupérez dans une chaîne de caractères la liste de tous les fichiers en utilisant la fonction fListeFichier.
  2. Parcourez la chaîne récupérée dans une boucle. Chaque fichier est séparé par un caractère RC.
  3. Traitez chaque fichier trouvé.
Exemple de code :
sListeFichier est une chaîne
sFic est une chaîne

sListeFichier = fListeFichier("C:\TEMP\*.DOC")

POUR TOUTE CHAÎNE sFic DE sListeFichier SEPAREE PAR RC
// Traitement du fichier sFic
// la variable sFic contient le nom du fichier à traiter

FIN
Méthode 2 : Utilisation d'une procédure "Callback" pour traiter chaque fichier séparément
Pour traiter chaque fichier listé séparément à l'aide d'une procédure WLangage :
  1. Créez une procédure locale ou interne pour traiter chaque fichier trouvé.
  2. Parcourez la liste de tous les fichiers en utilisant la fonction fListeFichier associée à la procédure créée précédemment.
Exemple de code :
PROCEDURE INTERNE pTraiteFichier(sRep, sFic)
// Traitement du fichier trouvé
// La variable sRep contient le répertoire du fichier
// La variable sFic contient le nom du fichier
Trace(sRep, sFic)
FIN

fListeFichier("C:\TEMP\*.DOC", pTraiteFic)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire