PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

PV


  • Méthode 1 : Utilisation de la fonction fLitLigne
  • Principe
  • Exemples de code
  • Méthode 2 : Utilisation la fonction fChargeTexte
  • Principe
  • Exemple de code
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Méthode 1 : Utilisation de la fonction fLitLigne

Principe

Pour lire une ligne dans un fichier texte ou CSV :
  1. Ouvrez le fichier à l'aide de la fonction fOuvre.
  2. Lisez la ligne à l'aide de la fonction fLitLigne.
  3. Fermez le fichier à l'aide de la fonction fFerme.

Exemples de code

  • Lecture d'une ligne :
    // Lecture d'une chaîne simple
    nNumFichier est un entier
    sLigneLue est une chaîne

    nNumFichier = fOuvre ("MonFichier.txt", foLecture)
    SI nNumFichier <> -1 ALORS
    // Lecture de la ligne
    sLigneLue = fLitLigne(nNumFichier)
    fFerme(nNumFichier)
    FIN
  • Lecture d'un fichier de données sous forme de TXT (import)
    nNumFichier est un entier
    sLigneLue est une chaîne

    nNumFichier = fOuvre ("ImportProduits.txt", foLecture)
    SI nNumFichier <> -1 ALORS
    sLigneLue = fLitLigne(nNumFichier) // Lecture de la 1ère ligne
    TANTQUE sLigneLue <> EOT // Test de la fin de fichier
    // Traitement de la ligne
    ...
    // Lecture de la ligne suivante
    sLigneLue = fLitLigne(nNumFichier)
    FIN
    fFerme(nNumFichier)
    FIN
Méthode 2 : Utilisation la fonction fChargeTexte

Principe

Pour lire un fichier texte ou CSV en une seule opération :
  1. Déclarez une variable de type chaîne.
  2. Chargez en mémoire dans cette variable tout le contenu du fichier à l'aide de la fonction fChargeTexte.
  3. Traitez la chaîne en mémoire pour analyser son contenu.

Exemple de code

// Lecture d'un fichier de données en TXT (import)

sContenuFichier est une chaîne
sLigne est une chaîne

// Chargement en mémoire du contenu du fichier
sContenuFichier = fChargeTexte("ImportProduits.txt")

POUR TOUT CHAÎNE sLigne DE sContenuFichier SEPAREE PAR RC
// Traitement de la ligne
...
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire