PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Méthode 1 : Utilisation la fonction fEcritLigne
  • Exemples de code
  • Méthode 2 : Utilisation de la fonction fSauveTexte
  • Principe
  • Exemples de code
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Méthode 1 : Utilisation la fonction fEcritLigne
Pour écrire une ligne dans un fichier texte ou CSV :
  1. Ouvrez le fichier (ou créez-le) à l'aide de la fonction fOuvre.
  2. Ecrivez la ligne à l'aide de la fonction fEcritLigne. La fonction fEcritLigne ajoute automatiquement un caractère RC en fin de ligne.
  3. Fermez le fichier à l'aide de la fonction fFerme.

Exemples de code

  • Ecriture d'une ligne :
    // Ecriture d'une chaîne simple
    nNumFichier est un entier
    sLigneAEcrire est une chaîne

    nNumFichier = fOuvre("MonFichier.txt", foCréation)
    SI nNumFichier <> -1 ALORS
    sLigneAEcrire = "Bonjour, nous sommes le " + DateVersChaîne(DateDuJour(), "JJJJ JJ MMMM AAAA")

    // Ecriture de la ligne
    fEcritLigne(nNumFichier, sLigneAEcrire)

    fFerme(nNumFichier)
    FIN
  • Conversion d'un fichier de données en TXT (export)
    <code WL>
    nNumFichier est un entier
    sLigneAEcrire est une chaîne

    nNumFichier = fOuvre ("ExportProduits.txt", foCréation)
    SI nNumFichier <> -1 ALORS
    POUR TOUT Produit
    // La ligne est composée de :
    // - la référence du produit
    // - le libellé du produit
    // - le prix du produit
    sLigneAEcrire = Produit.Reference + TAB + Produit.LibProd + TAB +
    NumériqueVersChaîne(Produit.Prix, "10,2fS")

    // Ecriture de la ligne
    fEcritLigne(nNumFichier, sLigneAEcrire)
    FIN
    fFerme(nNumFichier)
    FIN
Méthode 2 : Utilisation de la fonction fSauveTexte

Principe

Pour écrire (créer) un fichier texte ou CSV en une seule opération :
  1. Déclarez une variable de type chaîne.
  2. Ecrivez et cumulez en mémoire dans cette variable toutes les lignes du fichier.
  3. Enregistrez le contenu de cette variable dans un fichier à l'aide de la fonction fSauveTexte.

Exemples de code

// Conversion d'un fichier de données en TXT (export)
sLigneAEcrire est une chaîne
sContenuFichier est une chaîne

POUR TOUT Produit
// La ligne est composée de :
// - la référence du produit
// - le libellé du produit
// - le prix du produit
sLigneAEcrire = Produit.Reference + TAB + Produit.LibProd + TAB +
NumériqueVersChaîne(Produit.Prix, "10,2fS")

// Ecriture de la ligne en mémoire
sContenuFichier += sLigneAEcrire + RC
FIN
fSauveTexte ("ExportProduits.txt", sContenuFichier)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire