PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Fonction ArbreAjoute : Ajouter un élément à n'importe quelle position
  • Exemples de code
  • Fonction ArbreInsère : Insérer un élément à une position précise
  • Exemple de code
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Un champ Arbre permet de représenter de manière hiérarchique (sur plusieurs niveaux) des données. Par exemple, un champ Arbre peut représenter des produits classés par Famille puis Sous-famille.
Pour remplir un champ Arbre par programmation, il faut utiliser :
Fonction ArbreAjoute : Ajouter un élément à n'importe quelle position
La fonction ArbreAjoute permet d'ajouter un élément dans un champ Arbre. Un élément est composé de  :
  • Racine : représente le premier niveau de l'élément
  • Branche(s) : représente le (ou les) niveaux intermédiaires
  • Feuille : représente la donnée à classer
Un élément est représenté sous la forme :
Racine + TAB + Branche 1 + TAB + Branche 2 + TAB + ... + TAB + Feuille
La syntaxe de la fonction ArbreAjoute est la suivante :
ArbreAjoute(<Nom Arbre>, <élément>, <image enroulée>, <image déroulée>, <identifiant>)
Pour plus de détails, consultez la page d'aide de la fonction ArbreAJoute.

Exemples de code

  • Remplissage par programmation :
    ArbreAjoute(ARBRE_Ville, "France")
    ArbreAjoute(ARBRE_Ville, "Italie")
    ArbreAjoute(ARBRE_Ville, "France" + TAB + "Paris")
    ArbreAjoute(ARBRE_Ville, "France" + TAB + "Marseille")
    ArbreAjoute(ARBRE_Ville, "France" + TAB + "Lyon")
    ArbreAjoute(ARBRE_Ville, "France" + TAB + "Montpellier")
    ArbreAjoute(ARBRE_Ville, "Italie" + TAB + "Rome")
    ArbreAjoute(ARBRE_Ville, "Italie" + TAB + "Pise")
    ArbreAjoute(ARBRE_Ville, "Italie" + TAB + "Milan")
    ArbreAjoute(ARBRE_Ville, "Espagne" + TAB + "Barcelone")
    ArbreAjoute(ARBRE_Ville, "Espagne" + TAB + "Madrid")
    ArbreAjoute(ARBRE_Ville, "Espagne" + TAB + "Valence")
  • Remplissage à partir d'un fichier de données :
    // Lecture familles
    POUR TOUT Famille
    // Ajout de la famille dans l'arbre (niveau 1: racine)
    ArbreAjoute(ARBRE_Produits, Famille.libellé)

    // Lecture des sous-familles
    POUR TOUT SousFam AVEC IDFamille = Famille.IdFamille
    // Ajout de la sous-famille (niveau 2: branche 1)
    ArbreAjoute(ARBRE_Produits, Famille.libellé + TAB + SousFam.libellé)

    // Lecture des produits
    POUR TOUT PRODUIT AVEC IdSousFam = SousFam.IdSousFam
    // Ajout du produit : (feuille)
    ArbreAjoute(ARBRE_Produits,
    Famille.libellé + TAB + SousFam.libellé + TAB + PRODUIT.LibProd)
    FIN
    FIN
    FIN
Fonction ArbreInsère : Insérer un élément à une position précise
La fonction ArbreInsère permet d'insérer une feuille par rapport à une autre feuille (feuille frère).
La syntaxe de la fonction ArbreInsère est la suivante :
ArbreInsère(<Nom Arbre>, <Feuille frère>, <Nouvelle feuille>,
<Image enroulée>, <Image déroulée>, <Identifiant>)
Pour plus de détails, consultez la page d'aide de la fonction ArbreInsère.

Exemple de code

ArbreAjoute(ARBRE_Ville, "France")
ArbreAjoute(ARBRE_Ville, "Italie")
ArbreAjoute(ARBRE_Ville, "France" + TAB + "Paris")
ArbreAjoute(ARBRE_Ville, "France" + TAB + "Marseille")
ArbreAjoute(ARBRE_Ville, "France" + TAB + "Lyon")

// Insère les villes de Montpellier et Bordeaux au même niveau que Lyon
ArbreInsère(ARBRE_Ville, "France" + TAB + "Lyon", "Montpellier")
ArbreInsère(ARBRE_Ville, "France" + TAB + "Lyon", "Bordeaux")
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire