PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Présentation
  • Exemples d'application
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Comment manipuler les opérateurs d'indirection ?
Présentation
Les opérateurs d'indirection ({ }) permettent de manipuler un objet dont le nom est présent dans une variable.
Il est ainsi possible de construire par programmation le nom de l'objet à manipuler dans une variable et ensuite d'appliquer des actions pour connaître ou modifier les caractéristiques de cet objet.
La syntaxe est la suivante :
{ NomVariable, TypeObjet }..NomPropriété
dans laquelle :
  • NomVariable est une variable de type chaîne contenant le nom de l'objet à manipuler
  • TypeObjet est une constante indXXX représentant le type de l'objet à manipuler (champ, variable, fenêtre, etc.)
Pour plus de détails, consultez Opérateurs d'indirection.
Exemples d'application
NomChamp est une chaîne
NomChamp = "SAI_NOM"

// On change la couleur de fond du champ dont le nom est SAI_NOM
{NomChamp, indChamp}..CouleurFond = RougeClair
// Vider uniquement les champs de saisie de type TEXTE dans une fenêtre
nInd est un entier = 1
sNomChamp est une chaîne

sNomChamp = EnumèreChamp(FEN_Table, nInd)
TANTQUE sNomChamp<>""
SI {sNomChamp, indChamp}..Type = typSaisieTexte ALORS
{sNomChamp, indChamp} = ""
FIN

nInd++
sNomChamp = EnumèreChamp(FEN_Table, nInd)
FIN
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire