PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Déclaration d'une structure
  • Utilisation d'un tableau de structures
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Un tableau de structures est une variable de type Tableau. Chaque élément du tableau est de type Structure. Par exemple :
  • mémoriser un tableau de lignes de commandes.
  • mémoriser une liste de contacts.
Déclaration d'une structure
Pour déclarer une variable tableau de structures, il faut
  1. Déclarer la structure seule.
  2. Déclarer une variable tableau du type de la structure.
La syntaxe est la suivante
MaStructure est une Structure
Membre1 est un <type de variable>
Membre2 est un <type de variable>
...
FIN

MonTableau est un tableau de MaStructure
Par exemple :
stLigneCommande est une Structure
NumLigne est un entier
RefProduit est une chaîne
Qte est un entier
PrixUnitaire est un monétaire
FIN

tabLignesCde est un tableau de stLigneCommande
Utilisation d'un tableau de structures
Pour utiliser un tableau de structures, il faut :
  1. Déclarer une variable de type Tableau du type de la structure.
  2. Déclarer une variable simple représentant un élément du type de la structure.
  3. Initialiser les membres faisant partie de cette variable simple.
  4. Ajouter cette variable simple dans le tableau.
Par exemple :
stLigneCommande est une Structure
NumLigne est un entier
RefProduit est une chaîne
Qte est un entier
PrixUnitaire est un monétaire
FIN

UneLigneCde est un stLigneCommande
tabLignesCde est un tableau de stLigneCommande

// Remplissage du tableau

UneLigneCde.NumLigne = 1
UneLigneCde.RefProduit = "Ref001"
UneLigneCde.Qte = 5
UneLigneCde.PrixUnitaire = 100.0

TableauAjoute(tabLignesCde, UneLigneCde)

UneLigneCde.NumLigne = 2
UneLigneCde.RefProduit = "Ref005"
UneLigneCde.Qte = 1
UneLigneCde.PrixUnitaire = 2100.0

TableauAjoute(tabLignesCde, UneLigneCde)

UneLigneCde.NumLigne = 3
UneLigneCde.RefProduit = "Ref019"
UneLigneCde.Qte = 16
UneLigneCde.PrixUnitaire = 22.0

TableauAjoute(tabLignesCde, UneLigneCde)


// Relecture du tableau : méthode 1

POUR TOUT ELEMENT LigCde DE tabLignesCde
Trace(LigCde.RefProduit, LigCde.Qte, LigCde.Qte * LigCde.PrixUnitaire)

FIN


// Relecture du tableau : méthode 2

POUR nInd=1 À tabLignesCde..Occurrence
Trace(LigCde[nInd].RefProduit, LigCde[nInd].Qte, LigCde[nInd].Qte * LigCde[nInd].PrixUnitaire)

FIN
Notes
Les structures et les tableaux de structures peuvent être déclarés :
  • dans le code du projet (structure globale à tout le projet).
  • dans le code d'une fenêtre ou une page (structure globale à la fenêtre ou la page).
  • dans un traitement quelconque (structure locale au traitement).
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire