PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Utilisation de la fonction TableAjoute
  • Principe
  • Exemples de code
  • Utilisation de la fonction TableAjouteLigne
  • Principe
  • Exemples de code
  • Utilisation de la fonction FichierVersTableMémoire
  • Principe
  • Exemple de code
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Utilisation de la fonction TableAjoute

Principe

La fonction TableAjoute permet d'ajouter une ligne dans un champ de type Table géré par programmation. Pour ajouter la ligne, il faut :
  1. Déclarer une variable pour préparer la ligne à ajouter.
  2. Concaténer chaque valeur de colonne dans cette variable. Chaque valeur est séparée par un caractère TAB. La ligne à ajouter doit être sous la forme :
    Ligne = <Valeur Colonne 1> + TAB + <Valeur Colonne 2> + TAB + ... + TAB + <Valeur Colonne N>
  3. Ajouter la ligne à l'aide de la fonction TableAjoute.

Exemples de code

  • Ajout d'une ligne simple :
    sLigne est une chaîne
    sLigne = DateDuJour() + TAB + HeureSys() + TAB + "mon message..."
    TableAjoute(TABLE_messages, sLigne)
  • Ajout des enregistrements d'un fichier Produit dans un champ Table :
    sLigne est une chaîne

    // On vide le contenu de la table
    TableSupprimeTout(TABLE_Produits)

    POUR TOUT PRODUIT
    sLigne = Produit.Référence + TAB + Produit.LibProd + TAB + Produit.Prix
    TableAjoute(TABLE_Produits, sLigne)
    FIN
    Info("Il y a " + TableOccurrence(TABLE_Produits) + " produits ajoutés.")
Utilisation de la fonction TableAjouteLigne

Principe

La fonction TableAjouteLigne permet d'ajouter une ligne dans un champ de type Table géré par programmation. La différence avec la méthode précédente (utilisation de la fonction TableAjoute) est seulement une différence de syntaxe.

Exemples de code

  • Ajout d'une ligne simple :
    // Ajout d'une ligne simple
    TableAjouteLigne(TABLE_messages, DateDuJour(), HeureSys(), "mon message...")
  • Ajout des enregistrements d'un fichier Produit dans un champ Table :
    // Ajout d'un fichier PRODUIT dans une table
    sLigne est une chaîne

    // On vide le contenu de la table
    TableSupprimeTout(TABLE_Produits)

    POUR TOUT PRODUIT
    TableAjouteLigne(TABLE_Produits, Produit.Référence, Produit.LibProd, Produit.Prix)
    FIN

    Info("Il y a " + TableOccurrence(TABLE_Produits) + " produits ajoutés.")
  • Ajout des enregistrements d'un fichier Produit dans un champ Table (colonne par colonne) :
    <code WL>
    sLigne est une chaîne
    nNumLigneAjoutée est un entier

    // On vide le contenu de la table
    TableSupprimeTout(TABLE_Produits)

    POUR TOUT PRODUIT
    // On ajoute une ligne vide
    nNumLigneAjoutée = TableAjouteLigne(TABLE_Produits)

    // On modifie les colonnes séparément
    TABLE_Produits.Col_Ref[nNumLigneAjoutée] = Produit.Référence
    TABLE_Produits.Col_Lib[nNumLigneAjoutée] = Produit.LibProd
    TABLE_Produits.Col_Prix[nNumLigneAjoutée] = Produit.Prix

    FIN

    Info("Il y a " + TableOccurrence(TABLE_Produits) + " produits ajoutés.")
Utilisation de la fonction FichierVersTableMémoire

Principe

La fonction FichierVerstableMémoire permet de remplir à partir d'un fichier de données (ou d'une requête SQL) un champ Table géré par programmation en une seule opération (sans faire de boucle de remplissage).
Par contre, il est important que la structure du champ Table (format des colonnes et ordre des colonnes) corresponde exactement au format du fichier ou de la requête SQL : la rubrique 1 du fichier ou de la requête SQL va être associée à la colonne 1, puis la rubrique 2 du fichier ou de la requête SQL va être associée à la colonne 2, etc.

Exemple de code

TableSupprimeTout(TABLE_Produit)
FichierVersTableMémoire(TABLE_PRODUIT, Produit)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire