PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

PV


  • Principe
  • Exemples
  • Parcours des emails via une boucle de type POUR TOUT
  • Parcours des emails via une boucle de type TANTQUE
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Principe
Pour lire des emails via le protocole IMAP sans passer par un logiciel de messagerie :
  1. Récupérez les paramètres de connexion à votre serveur de messagerie. Ces paramètres sont fournis par votre fournisseur de services ou par votre administrateur réseau.
  2. Déclarez une variable de type emailSessionIMAP et l'initialiser avec les paramètres récupérés précédemment.
  3. Connectez-vous au serveur de messagerie via la fonction EmailOuvreSessionIMAP.
  4. Réalisez une boucle afin de lire les emails du début jusqu'à la fin en utilisant les fonctions EmailLitPremier et EmailLitSuivant. La variable Email.Endehors vaut :
    • Vrai si il n'y a plus de messages à lire.
    • Faux dans le cas contraire.
  5. Utilisez une variable de type Email pour récupérer le contenu de l'email qui a été lu.
  6. Fermez la session IMAP en utilisant la fonction EmailFermeSession.
Exemples

Parcours des emails via une boucle de type POUR TOUT

MonMessage est un Email
MaSessionIMAP est un emailSessionIMAP

// Ouverture d'une session IMAP simple
MaSessionIMAP..AdresseServeur = "imap.masociete.fr"
MaSessionIMAP..Nom = "utilisateur"
MaSessionIMAP..MotDePasse = "secret"

// On ouvre la session IMAP
SI PAS EmailOuvreSession(MaSessionIMAP) ALORS
// Erreur d'ouverture de session IMAP
Erreur("Impossible d'ouvrir la session IMAP.", ErreurInfo())
SINON
// Lecture des messages
POUR TOUT MonMessage NON LU DE MaSessionIMAP
// On traite le message lu
Trace(MonMessage..Sujet, MonMessage..Expediteur, MonMessage..Message)
FIN
// On se déconnecte de la session
EmailFermeSession(MaSessionIMAP)
FIN

Parcours des emails via une boucle de type TANTQUE

MonMessage est un Email
MaSessionIMAP est un emailSessionIMAP

// Ouverture d'une session IMAP simple
MaSessionIMAP..AdresseServeur = "imap.masociete.fr"
MaSessionIMAP..Nom = "utilisateur"
MaSessionIMAP..MotDePasse = "secret"

// On ouvre la session IMAP
SI PAS EmailOuvreSession(MaSessionIMAP) ALORS
// Erreur d'ouverture de session IMAP
Erreur("Impossible d'ouvrir la session IMAP.", ErreurInfo())
SINON

// Lecture des messages
EmailLitPremier(MaSessionIMAP, MonMessage)
TANTQUE PAS Email.EnDehors
// On traite le message lu
Trace(MonMessage..Sujet, MonMessage..Expediteur, MonMessage..Message)
// On lit le message suivant
EmailLitSuivant(MaSessionIMAP, MonMessage)
FIN
// On se déconnecte de la session
EmailFermeSession(MaSessionIMAP)

FIN
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire