PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

PV


  • Principe
  • Exemple
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Principe
Pour lire des emails via le protocole POP3 sans passer par un logiciel de messagerie, il faut :
  1. Récupérer les paramètres de connexion à votre serveur POP3 (Ces paramètres sont fournis par votre fournisseur de services ou par votre administrateur réseau). Ces paramètres doivent être mémorisés via une variable de type emailSessionPOP3.
  2. Se connecter au serveur POP3 via la fonction EmailOuvreSessionPOP3.
  3. Faire une boucle pour lire les emails du début jusqu'à la fin en utilisant les fonctions EmailLitPremier et EmailLitSuivant. La variable Email.Endehors vaut :
    • Vrai si il n'y a plus de messages à lire.
    • Faux dans le cas contraire.
  4. Utiliser une variable de type Email pour récupérer le contenu de l'email qui a été lu.
  5. Fermer la session POP3 en utilisant la fonction EmailFermeSession.
Exemple
MonMessage est un Email
MaSessionPOP3 est un emailSessionPOP3


// Session POP3 simple
MaSessionPOP3..AdresseServeur = "pop3.masociete.fr"
MaSessionPOP3..Nom = "utilisateur"
MaSessionPOP3..MotDePasse = "secret"

// Ouverture de la session POP3
SI PAS EmailOuvreSession(MaSessionPOP3) ALORS
// Erreur d'ouverture de session POP3
Erreur("Impossible d'ouvrir la session POP3.", ErreurInfo())
SINON

// Lecture des messages
EmailLitPremier(MaSessionPOP3, MonMessage)
TANTQUE PAS Email.EnDehors
// Traitement du message lu
Trace(MonMessage..Sujet, MonMessage..Expediteur, MonMessage..Message)

// Lecture du message suivant
EmailLitSuivant(MaSessionPOP3, MonMessage)
FIN

// Déconnexion de la session
EmailFermeSession(MaSessionPOP3)

FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire