PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

PV


  • Présentation
  • Méthode 1 : Utilisation de la fonction ListeSelect
  • Exemple
  • Méthode 2 : Utilisation de l'instruction POUR TOUT
  • Exemple
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
Par défaut, un champ Liste permet de sélectionner et récupérer un seul élément parmi les éléments proposés. La liste est en mono-sélection.
Il est cependant possible de paramétrer le champ Liste afin qu'il permettent de réaliser une multi-sélection. Dans ce cas, l'utilisateur peut sélectionner plusieurs éléments et il est possible de récupérer les éléments sélectionnés par programmation.
Le paramètre "Multi-sélection" du champ Liste est disponible dans l'onglet "IHM" de la fenêtre de description du champ.
L'utilisateur peut réaliser une multisélection à l'aide des touches standards du clavier Maj, Ctrl, les flèches de déplacement et/ou la souris.
Il existe 2 méthodes pour récupérer les éléments sélectionnés :
Méthode 1 : Utilisation de la fonction ListeSelect
Cette méthode consiste à faire une boucle de parcours des éléments à l'aide de la fonction ListeSelect.
Une variable représentant le rang de l'élément sélectionné va être incrémentée à partir de la valeur 1.
  • Si la fonction ListeSelect renvoie la valeur -1 : il n'y a pas ou plus d'élément sélectionné.
  • Si la fonction ListeSelect renvoie une valeur supérieure à 0 : cette valeur représente la position de l'élément sélectionné dans le champ Liste.
Pour récupérer la valeur de l'élément sélectionné, utilisez la syntaxe suivante :
NomChampListe[Indice]
Note : Il est possible de connaître le nombre d'éléments sélectionnés à l'aide de la fonction ListeSelectOccurrence. Il est ainsi possible de faire une boucle avec un POUR et non pas un TANTQUE.

Exemple

Rang est un entier
PositionElement est un entier
ValeurElement est une chaîne

Rang = 1
PositionElement = ListeSelect(NomListe, Rang)
TANTQUE PositionElement<>-1
ValeurElement = NomListe[PositionElement]
Rang++
PositionElement = ListeSelect(NomListe, Rang)
FIN
Méthode 2 : Utilisation de l'instruction POUR TOUT
Cette méthode permet de parcourir directement la liste des éléments sélectionnés avec une instruction POUR TOUT spécifique.

Exemple

ValeurElement est une chaîne
POUR TOUT LIGNE SELECTIONNEE DE NomListe
ValeurElement = NomListe..ValeurAffichée
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire