PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation
  • Méthode 1 : Fonctions de parcours
  • Exemple
  • Méthode 2 : Instruction POUR TOUT
  • Exemple de code
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
Deux méthodes permettent de réaliser le parcours complet d'un fichier de données :
Méthode 1 : Fonctions de parcours
Cette méthode utilise les fonctions de base du WLangage pour parcourir les fichiers de données :
Dans cette méthode :
  • La fonction HLitPremier permet d'accéder au premier enregistrement en fonction de la clé de parcours.
  • La fonction HLitSuivant permet d'accéder à l'enregistrement suivant (dans l'ordre de la clé de parcours).
  • La fonction HEnDehors permet de savoir si la fin du fichier de données est atteinte.
Note : Il est possible d'utiliser les fonctions HLitDernier et HLitPrécédent pour effectuer un parcours inverse.

Exemple

// Parcours de tous les enregistrements du fichier de données client
// trié par Nom du client.

HLitPremier(CLIENT, NomClient)
TANTQUE PAS HEnDehors(CLIENT)
// Traitement de l'enregistrement CLIENT
HLitSuivant(CLIENT, NomClient)
FIN
Méthode 2 : Instruction POUR TOUT
L'instruction POUR TOUT permet de parcourir les enregistrements d'un fichier de données. Dans notre cas, cette instruction va permettre de lire les enregistrements d'un fichier de données.
L'instruction POUR TOUT attend les paramètres suivants :
  • le nom du fichier à parcourir
  • le nom de l'index (ou clé) pour trier les enregistrements
Les lectures du premier enregistrement et de l'enregistrement suivant sont effectuées par l'instruction POUR TOUT. Il n'est pas nécessaire d'utiliser les fonctions HLitXXX.
Note : Il est possible d'utiliser le mot DESC pour effectuer un parcours inverse.

Exemple de code

// Parcours de tous les enregistrements du fichier client.
// Parcours trié par nom croissant

POUR TOUT CLIENT sur NomClient
// Traitement de l'enregistrement CLIENT


FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire