PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Méthode
  • Exemple
  • Notes
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Une requête SQL peut être créée directement via l'éditeur de requêtes (voir Création d'une requête en code SQL). Toutefois, il peut être pratique de créer directement par programmation une requête SQL.
Méthode
Pour créer directement par programmation une requête SQL :
  1. Déclarez une variable de type chaîne dans laquelle sera mémorisée le code SQL de la requête.
  2. Déclarez une variable de type source de données. Cette variable représentera la requête en exécution.
  3. Utilisez la fonction HExécuteRequêteSQL pour exécuter la requête.
  4. Pour lire et récupérer le résultat de la requête, utilisez les fonctions standard de lecture : HLitXXX, POUR TOUT, ...
  5. Ne pas oublier de libérer la requête à la fin de son utilisation (fonction HLibèreRequête).
Astuce
Si la requête utilise des paramètres provenant de variables, utilisez la fonction ChaîneConstruit pour construire la chaîne représentant le code SQL. Cette astuce est utilisée dans l'exemple ci-dessous.
Exemple
CodeSQL est une chaîne
SD est une Source de Données

CodeSQL = [
SELECT NomClient, Ville FROM CLIENTS
WHERE Pays='%1'
]

// Liste des clients de France
CodeSQL = ChaîneConstruit(CodeSQL, "FRANCE")

SI HExécuteRequêteSQL(SD, cnxBase, hRequêteSansCorrection, CodeSQL) ALORS
// Parcours du résultat
POUR TOUT SD
// Traitement de l'enregistrement lu
Trace(SD.NomClient, SD.Ville)
FIN

HLibèreRequête(SD)
SINON
Info("Erreur lors de l'exécution de la requête.")
FIN
Notes
Ce mode de création d'une requête peut présenter certains inconvénients :
  • pas de complétion (assistance) sur les noms des rubriques.
  • il est nécessaire de connaître, voire de maîtriser le langage SQL.
  • pas d'assistance à la saisie du code SQL.
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire