PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation du champ "Fenêtre interne"
  • Champ d'une fenêtre
  • Créer une fenêtre interne et l'associer à un champ
  • Créer une fenêtre interne
  • Créer un champ de type "Fenêtre interne"
  • Créer une fenêtre interne à partir de champs existants
  • Créer une fenêtre interne à partir d'une fenêtre et inversement
  • Remarques
  • Limitations
  • Appliquer le gabarit du projet
  • Appliquer un modèle de fenêtre à une fenêtre interne
  • Afficher l'aperçu des fenêtres internes à 100%
Produits
WINDEVWEBDEV - Code ServeurWEBDEV - Code NavigateurWINDEV MobileEtats et Requêtes
Plateformes
WindowsLinuxWindows MobileUniversal Windows 10 AppAndroidWidget AndroidiPhone/iPadApple Watch
Langages
JavaPHPAjaxCode Utilisateur (MCU)Langage Externe
Bases de données
HFSQLHFSQL Client/ServeurProcédures stockéesOLE DBODBCAccès Natifs
Présentation du champ "Fenêtre interne"

Champ d'une fenêtre

Le champ "Fenêtre Interne" permet d'inclure une fenêtre (et son code) dans un champ d'une autre fenêtre.
A l'exécution, la fenêtre à fusionner (fenêtre de type "Fenêtre interne") sera dynamiquement fusionnée à la fenêtre de réception.
Le champ "Fenêtre Interne" permet de partager dynamiquement une même partie d'interface au sein d'une ou plusieurs applications. La fenêtre à fusionner (fenêtre interne) peut également être issue d'un composant.
Attention : Ne confondez pas "Champ Fenêtre Interne" et "Fenêtre interne" : le champ "Fenêtre interne" est un type de champ et la "Fenêtre interne" est un type de fenêtre.
Versions 16 et supérieures
WINDEV MobileAndroid Ce champ est désormais disponible pour les applications Android.
Nouveauté 16
WINDEV MobileAndroid Ce champ est désormais disponible pour les applications Android.
WINDEV MobileAndroid Ce champ est désormais disponible pour les applications Android.
Versions 17 et supérieures
WINDEV MobileiPhone/iPad Ce champ est désormais disponible pour les applications iPhone/iPad.
AndroidJava Il est désormais possible de créer des fenêtres internes avec ascenseurs.
Nouveauté 17
WINDEV MobileiPhone/iPad Ce champ est désormais disponible pour les applications iPhone/iPad.
AndroidJava Il est désormais possible de créer des fenêtres internes avec ascenseurs.
WINDEV MobileiPhone/iPad Ce champ est désormais disponible pour les applications iPhone/iPad.
AndroidJava Il est désormais possible de créer des fenêtres internes avec ascenseurs.
Versions 18 et supérieures
WINDEVWINDEV MobileUniversal Windows 10 App Ce champ est désormais disponible pour les applications en mode Windows Store apps.
Nouveauté 18
WINDEVWINDEV MobileUniversal Windows 10 App Ce champ est désormais disponible pour les applications en mode Windows Store apps.
WINDEVWINDEV MobileUniversal Windows 10 App Ce champ est désormais disponible pour les applications en mode Windows Store apps.
Versions 20 et supérieures
WINDEVLinux Ce champ est désormais disponible pour les applications WINDEV sous Linux.
Nouveauté 20
WINDEVLinux Ce champ est désormais disponible pour les applications WINDEV sous Linux.
WINDEVLinux Ce champ est désormais disponible pour les applications WINDEV sous Linux.
Créer une fenêtre interne et l'associer à un champ

Créer une fenêtre interne

Pour créer une fenêtre interne :
  1. Sélectionnez l'option de menu "Fichier .. Nouveau .. Fenêtre".Cliquez sur Nouveau parmi les boutons d'accès rapide.
  2. Cliquez sur l'onglet "Fenêtre interne" et sélectionnez "Vierge" (si nécessaire sélectionnez également le gabarit associé).Dans la roue qui s'affiche, cliquez sur "Fenêtre". L'assistant de création d'une fenêtre se lance automatiquement.La fenêtre de création d'un nouvel élément s'affiche : cliquez sur "Fenêtre" puis sur "Fenêtre". L'assistant de création d'une fenêtre se lance automatiquement.
  3. Validez pour créer la fenêtre.Cliquez sur l'onglet "Fenêtre interne" et sélectionnez "Vierge" (si nécessaire sélectionnez également le gabarit associé). Validez pour créer la fenêtre.
Une fenêtre interne correspond à un type particulier de fenêtre. La fenêtre interne ne comporte aucun cadre, barre de titre, barre de message et image de fond. Elle est destinée à s'afficher dans un champ de type "Fenêtre interne".
Ce type de fenêtre est également appelé "Fenêtre source".
Remarques :
  • Dans l'onglet "IHM" de la fenêtre de description, vous pouvez indiquer si la fenêtre source doit reprendre le gabarit de la fenêtre cible. Il suffit pour cela de cocher l'option "Appliquer le gabarit du projet de la fenêtre hôte".
  • Il est également possible de créer une fenêtre interne vierge par l'option "Fichier .. Nouveau .. Fenêtre .. Fenêtre interne".Il est également possible de créer une fenêtre interne vierge de la façon suivante :
    • Cliquez sur Nouveau parmi les boutons d'accès rapide.
    • Dans la roue qui s'affiche, survolez "Fenêtre" et cliquez sur "Fenêtre interne".La fenêtre de création d'un nouvel élément s'affiche : cliquez sur "Fenêtre" puis sur "Fenêtre interne".
    • La fenêtre interne est automatiquement créée sous l'éditeur.
  • Versions 22 et supérieures
    Si la fenêtre interne est utilisée sur différentes plateformes, en mode portrait ou paysage, il est possible de définir des agencements. Pour plus de détails, consultez Gestion des agencements.
    Nouveauté 22
    Si la fenêtre interne est utilisée sur différentes plateformes, en mode portrait ou paysage, il est possible de définir des agencements. Pour plus de détails, consultez Gestion des agencements.
    Si la fenêtre interne est utilisée sur différentes plateformes, en mode portrait ou paysage, il est possible de définir des agencements. Pour plus de détails, consultez Gestion des agencements.

Créer un champ de type "Fenêtre interne"

Pour créer un champ de type "Fenêtre interne" :
  1. Sous l'éditeur de fenêtres, cliquez sur l'icône Champ Fenêtre Interne (ou sélectionnez l'option "Insertion .. Spécial .. Champ Fenêtre interne").Sous le volet "Création", dans le groupe "Conteneurs", cliquez sur "Fenêtre interne".
  2. Cliquez dans la fenêtre cible à la position où le champ doit être créé. Le champ apparaît en création.
Pour afficher les caractéristiques du champ, sélectionnez l'option "Description" dans le menu contextuel du champ. Vous pourrez ainsi sélectionner la fenêtre interne qui sera affichée dans le champ "fenêtre interne" à l'initialisation de la fenêtre cible.
Versions 18 et supérieures
AndroidiPhone/iPad Il est possible de faire défiler des fenêtres internes dans un champ fenêtre interne par un simple mouvement de doigt. Pour plus de détails, consultez Changement du contenu d'une fenêtre interne par gesture.
Nouveauté 18
AndroidiPhone/iPad Il est possible de faire défiler des fenêtres internes dans un champ fenêtre interne par un simple mouvement de doigt. Pour plus de détails, consultez Changement du contenu d'une fenêtre interne par gesture.
AndroidiPhone/iPad Il est possible de faire défiler des fenêtres internes dans un champ fenêtre interne par un simple mouvement de doigt. Pour plus de détails, consultez Changement du contenu d'une fenêtre interne par gesture.

Créer une fenêtre interne à partir de champs existants

Pour créer une fenêtre interne à partir de champs existants :
  1. Sélectionnez les champs devant être présents dans la fenêtre interne.
  2. Utilisez une des méthodes suivantes :
    • Affichez le menu contextuel de la sélection et choisissez l'option "Refactoring .. Créer une fenêtre interne avec la sélection".
    • Sélectionnez l'option de menu "Champ .. Refactoring .. Créer une fenêtre interne avec la sélection".Sous le volet "Modification", dans le groupe "Transformations", déroulez "Refactoring et permutations" et sélectionnez "Créer une fenêtre interne avec la sélection".
Le champ fenêtre interne et la fenêtre interne sont automatiquement créés. La fenêtre interne est automatiquement associée au champ.

Créer une fenêtre interne à partir d'une fenêtre et inversement

  • Pour créer une fenêtre interne à partir de la fenêtre en cours, sélectionnez l'option "Fichier .. Enregistrer comme une fenêtre interne".Pour créer une fenêtre interne à partir de la fenêtre en cours, sous le volet "Accueil", dans le groupe "Général", déroulez "Enregistrer" et sélectionnez "Enregistrer comme une fenêtre interne".
  • Pour créer une fenêtre à partir de la fenêtre interne en cours, sélectionnez l'option "Fichier .. Enregistrer comme une fenêtre".Pour créer une fenêtre à partir de la fenêtre interne en cours, sous le volet "Accueil", dans le groupe "Général", déroulez "Enregistrer" et sélectionnez "Enregistrer comme une fenêtre".
Remarques

Limitations

Des menus principaux peuvent être créés dans des champs fenêtre interne, mais ils seront inactifs.

Appliquer le gabarit du projet

Si la fenêtre interne fait partie d'un composant, il est possible d'appliquer le gabarit du projet hôte sur la fenêtre interne (option "Appliquer le gabarit du projet hôte (composant uniquement)" de l'onglet "IHM" de la description de la fenêtre interne).
Cette option n'est pas prise en compte si la fenêtre interne n'est pas présente dans un composant.
Versions 20 et supérieures

Appliquer un modèle de fenêtre à une fenêtre interne

Pour appliquer un ou plusieurs modèles de fenêtres sur une fenêtre interne :
  1. Affichez la fenêtre interne sous l'éditeur de fenêtres.
  2. Sous le volet "Fenêtre", dans le groupe "Modèles", déroulez "Modèles" et sélectionnez "Hériter d'un modèle".
  3. Sélectionnez le modèle de fenêtres à appliquer.
  4. Validez.
  5. Indiquez si vous souhaitez mettre à jour les propriétés de la fenêtre interne depuis le modèle. Si vous répondez "Oui", la liste des propriétés à surcharger apparaît. Dans cette fenêtre, vous pouvez sélectionner les propriétés de la fenêtre interne à conserver. Le modèle de fenêtres appliqué sera automatiquement surchargé pour les propriétés conservées. Pour toutes les autres caractéristiques, la fenêtre interne sera automatiquement liée au modèle.
  6. Validez.
Remarque : Par défaut, les caractéristiques de taille de la fenêtre interne sont automatiquement surchargées.
Nouveauté 20

Appliquer un modèle de fenêtre à une fenêtre interne

Pour appliquer un ou plusieurs modèles de fenêtres sur une fenêtre interne :
  1. Affichez la fenêtre interne sous l'éditeur de fenêtres.
  2. Sous le volet "Fenêtre", dans le groupe "Modèles", déroulez "Modèles" et sélectionnez "Hériter d'un modèle".
  3. Sélectionnez le modèle de fenêtres à appliquer.
  4. Validez.
  5. Indiquez si vous souhaitez mettre à jour les propriétés de la fenêtre interne depuis le modèle. Si vous répondez "Oui", la liste des propriétés à surcharger apparaît. Dans cette fenêtre, vous pouvez sélectionner les propriétés de la fenêtre interne à conserver. Le modèle de fenêtres appliqué sera automatiquement surchargé pour les propriétés conservées. Pour toutes les autres caractéristiques, la fenêtre interne sera automatiquement liée au modèle.
  6. Validez.
Remarque : Par défaut, les caractéristiques de taille de la fenêtre interne sont automatiquement surchargées.

Appliquer un modèle de fenêtre à une fenêtre interne

Pour appliquer un ou plusieurs modèles de fenêtres sur une fenêtre interne :
  1. Affichez la fenêtre interne sous l'éditeur de fenêtres.
  2. Sous le volet "Fenêtre", dans le groupe "Modèles", déroulez "Modèles" et sélectionnez "Hériter d'un modèle".
  3. Sélectionnez le modèle de fenêtres à appliquer.
  4. Validez.
  5. Indiquez si vous souhaitez mettre à jour les propriétés de la fenêtre interne depuis le modèle. Si vous répondez "Oui", la liste des propriétés à surcharger apparaît. Dans cette fenêtre, vous pouvez sélectionner les propriétés de la fenêtre interne à conserver. Le modèle de fenêtres appliqué sera automatiquement surchargé pour les propriétés conservées. Pour toutes les autres caractéristiques, la fenêtre interne sera automatiquement liée au modèle.
  6. Validez.
Remarque : Par défaut, les caractéristiques de taille de la fenêtre interne sont automatiquement surchargées.

Afficher l'aperçu des fenêtres internes à 100%

Par défaut, les fenêtres internes affichées dans les champs de type "Fenêtre interne" sont réduites sous l'éditeur.
Pour afficher l'aperçu des fenêtres internes à 100% pour tout le projet, il suffit de cocher l'option "Forcer l'aperçu des fenêtres internes à 100%" dans les options d'édition de l'éditeur de fenêtres (option "Affichage .. Options .. Modifier les options", onglet "Champs").Pour afficher l'aperçu des fenêtres internes à 100% pour tout le projet :
  1. Sous le volet "Affichage", cliquez sur l'icône de regroupement (Regroupement) du groupe "Options".
  2. Dans l'onglet "Champs" des options d'édition, cochez l'option "Forcer l'aperçu des fenêtres internes à 100%".
  3. Validez.
Pour afficher l'aperçu d'une fenêtre interne à 100%, il suffit de cocher l'option "Toujours afficher l'aperçu à 100%" dans l'onglet "IHM" de la fenêtre de description du champ Fenêtre interne.
Liste des exemples associés :
WD Explorer Bar Composants (WINDEV) : WD Explorer Bar
[ + ] Le composant WD Explorer Bar permet de gérer une barre d'adresse similaire à la barre d'adresse de l'explorateur de Windows Vista.
Cette barre d'adresse (aussi appelée 'Explorer Breadcrumb') permet de naviguer dans un arbre, rapidement et facilement.
Il est possible d'ajouter des éléments par programmation, à la manière d'un champ Arbre.
Il est également possible de remplir la barre d'adresse grâce à un champ Arbre, et même depuis un ou plusieurs fichiers de données HFSQL.
La navigation dans la barre est gérée automatiquement par le composant grâce à une fenêtre interne.
Il est cependant possible de brancher l'appel à une procédure utilisateur WLangage lorsqu'un élément est cliqué.
WD Transfert de fichiers par FTP Exemples complets (WINDEV) : WD Transfert de fichiers par FTP
[ + ] WD Transfert de fichiers par FTP

Cet exemple est un client FTP complet vous permettant de mémoriser plusieurs serveurs FTP. Vous pouvez alors effectuer des transferts multi-fichiers du poste local vers le serveur ou du serveur FTP vers le poste local. On utilise pour cela les fonctions standards du WLangage (FTPConnecte, etc...)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire