PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation
  • Exemples
  • Exemple 1
  • Exemple 2
  • Exemple 3
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Comment remplir un champ Arbre à partir d'un fichier de données ?
Présentation
Versions 16 et supérieures
WINDEVWindows Mobile A partir de la version 16, le databinding est proposé sur les champs Arbre : le champ peut être directement lié à un fichier de données ou à une variable. Pour plus de détails, consultez Champ Arbre lié à une variable ou un fichier de données.
Nouveauté 16
WINDEVWindows Mobile A partir de la version 16, le databinding est proposé sur les champs Arbre : le champ peut être directement lié à un fichier de données ou à une variable. Pour plus de détails, consultez Champ Arbre lié à une variable ou un fichier de données.
WINDEVWindows Mobile A partir de la version 16, le databinding est proposé sur les champs Arbre : le champ peut être directement lié à un fichier de données ou à une variable. Pour plus de détails, consultez Champ Arbre lié à une variable ou un fichier de données.
Par défaut, le champ Arbre ne peut pas afficher automatiquement les données provenant d'un fichier de données.
Voici quelques exemples permettant de réaliser cette opération.
Voici un algorithme permettant de remplir un champ Arbre à partir d'un fichier de données :
// Parcours du fichier
HLitPremier(NomFichier, NomClé)
TANTQUE HEnDehors() = Faux
       // Ajout dans l'arbre
        ArbreAjoute(NomChampArbre, MaRacine + TAB + Branche + TAB + Feuille)
        HLitSuivant(NomFichier, NomClé)
FIN
Exemples

Exemple 1

// Parcours du fichier
HLitPremier(Societe, Ville)
TANTQUE HEnDehors() = Faux
       // Ajout dans l'arbre
        ArbreAjoute(ChampArbre, Societe.Ville + TAB + Societe.NomSoc)
        HLitSuivant(Societe, Ville)
FIN

Exemple 2

// Parcours du fichier
HLitPremier(Client, NomCli)
TANTQUE HEnDehors() = Faux
       // Ajout dans l'arbre
        ArbreAjoute(ChampArbre, Gauche(Client.NomCli, 1) + TAB + Client.NomCli)
        HLitSuivant(Client, NomCli)
FIN

Exemple 3

// Parcours du fichier
POUR TOUT Client sur NomCli
       // Ajout dans l'arbre
        ArbreAjoute(ChampArbre, Gauche(Client.NomCli, 1) + TAB + Client.NomCli)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire