PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WINDEV Mobile 23 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
ArbreRécupèreIndice (Fonction)
En anglais : TreeGetSubscript
Renvoie l'indice d'un élément (noeud ou feuille) dans un champ Arbre.
Remarque : Cette fonction permet par exemple de récupérer l'indice pour appeler les propriétés sur la ligne d'un champ Arbre en utilisant la syntaxe :
Nom_Arbre[Indice]..<Nom Propriété> = ...
Exemple
// Passer en rouge la ligne feuille
nIndice est un entier
nIndice = ArbreRécupèreIndice(ARBRE_Arbre1, "Racine" + TAB + "Noeud" + TAB + "Feuille")
SI nIndice > 0 ALORS
// Vérifie que le noeud est visible avant de le manipuler
SI ARBRE_Arbre1[nIndice] = -1 ALORS
// Le noeud n'est pas visible : on le déroule pour le rendre visible
ArbreDéroule(ARBRE_Arbre1, "Racine" + TAB + "Noeud" + TAB + "Feuille")
FIN
// Modifie sa couleur
ARBRE_Arbre1[nIndice]..Couleur = RougeFoncé
FIN
Syntaxe
<Résultat> = ArbreRécupèreIndice(<Champ Arbre> , <Chemin de l'élément>)
<Résultat> : Entier
  • Indice si l'élément a été trouvé.
    Attention : La manipulation du noeud est possible uniquement si celui-ci est visible (c'est-à-dire s'il est déroulé).
  • -1 si l'élément n'existe pas.
<Champ Arbre> : Nom de champ
Nom du champ Arbre à manipuler.
<Chemin de l'élément> : Chaîne de caractères
Chemin complet de l'élément à supprimer. Ce paramètre est de la forme :
"<Nom de la racine>" + TAB + ["<Nom du 1er noeud>" + TAB + ...
["<Nom du 2ème noeud>" + TAB + [...]]]"<Nom de la feuille>"
En cas de doublons sur un élément du chemin, ce chemin peut contenir l'identifiant de l'élément (indiqué à la suite du nom grâce à la fonction ArbreID).
Composantes
WINDEVEtats et Requêtes wd230obj.dll
Windows Mobile wp230obj.dll
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire