PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 23 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
FenAttenteFin (Fonction)
En anglais : WaitWindowEnd
Ferme la fenêtre d’attente de l’application ouverte avec la fonction FenAttenteDébut.
Exemple
// Télécharge une image sur Internet et l’affiche dans un champ Image de l’application

// Affichage de la fenêtre d’attente
FenAttenteDébut("Téléchargement de l’image ...")

// Lancement du thread de téléchargement
ThreadExécute("MonThread", threadNormal, procTelechargementImage)
PROCÉDURE INTERNE procTelechargementImage
// Téléchargement de l'image
SI HTTPRequête("http://www.pcsoft.fr/img/visuels/pcsoft/logo-pcsoft.png") ALORS
bufImage est un Buffer = HTTPDonneRésultat()
// Affiche l'image téléchargée dans un champ image de la fenêtre
ExécuteThreadPrincipal(procMajImage)
PROCÉDURE INTERNE procMajImage
IMG_SansNom1 = bufImage
FIN
// Fermeture de la fenêtre d’attente
FenAttenteFin()
FIN
FIN
Syntaxe
FenAttenteFin()
Remarques
  • Pour que la fenêtre d’attente soit fermée, il est nécessaire d’appeler la fonction FenAttenteFin autant de fois que la fonction FenAttenteDébut a été appelée.
  • Il est possible d’appeler les fonctions FenAttenteDébut et FenAttenteFin depuis un thread secondaire.
Composantes
Android wd230android.jar
Version minimum requise
  • Version 23
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire