PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 23 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Crée un lecteur permettant de lire un document XML sans le charger en mémoire.
Exemple
MonNoeud est un xmlNoeud
MonNoeud..Type = XMLBalise
MonNoeud..Nom = "MonNoeud"
MonNoeud..Texte = "Le texte du noeud"

Lecteur est un xmlLecteur = XMLOuvreLecteur("fichier.xml")

POUR TOUT Lecteur EN PROFONDEUR
Trace(Lecteur..Type)
FIN

Lecteur2 est un xmlLecteur = XMLOuvreLecteur("fichier.xml")

POUR TOUT x DE Lecteur2
SI Lecteur2..Type = XMLLecteurBaliseDébut _OU_ Lecteur2..Type = XMLLecteurBaliseVide ALORS
SI Lecteur2..Nom = "config" ALORS
POUR TOUT y DE x
Trace(x..Nom)
FIN
FIN
FIN
FIN
Syntaxe
<Résultat> = XMLOuvreLecteur(<Fichier>)
<Résultat> : Variable de type xmlLecteur
Variable de type xmlLecteur permettant de lire un document XML sans le charger en mémoire.
<Fichier> : Chaîne de caractères (avec guillemets)
Chemin du fichier contenant le document XML à lire.
Remarques
Cette fonction permet de lire des fichiers XML de taille importante. Pour lire des petits fichiers XML, utilisez la fonction XMLOuvre.
Composantes
WINDEVWEBDEV - Code ServeurEtats et Requêtes wd230xml.dll
Linux wd230xml.so
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire