PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 23 !
  • Propriétés spécifiques à la description des variables de type xmlLecteur
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le type xmlLecteur permet de lire un document XML sans le charger en mémoire. Les caractéristiques de ce document XML peuvent être lues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
MonNoeud est un xmlNoeud
MonNoeud..Type = XMLBalise
MonNoeud..Nom = "MonNoeud"
MonNoeud..Texte = "Le texte du noeud"

Lecteur est un xmlLecteur = XMLOuvreLecteur("fichier.xml")

POUR TOUT Lecteur EN PROFONDEUR
Trace(Lecteur..Type)
FIN

Lecteur2 est un xmlLecteur = XMLOuvreLecteur("fichier.xml")

POUR TOUT x DE Lecteur2
SI Lecteur2..Type = XMLLecteurBaliseDébut _OU_ Lecteur2..Type = XMLLecteurBaliseVide ALORS
SI Lecteur2..Nom = "config" ALORS
POUR TOUT y DE x
Trace(x..Nom)
FIN
FIN
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type xmlLecteur

Les propriétés suivantes peuvent être utilisées pour manipuler un document XML :
Nom de la propriétéType manipuléEffet
AttributTableau de xmlAttributTableau des attributs XML associés au noeud.
NamespaceVariable de type xmlNamespaceEspace de nommage du noeud.
Cette propriété est disponible en lecture seulement.
NamespaceDéclaréTableau de xmlNamespaceTableau des namespaces XML déclarés par le noeud.
NomChaîne de caractères UnicodeNom du noeud.
Cette propriété est disponible en lecture seulement.
ProfondeurEntierProfondeur de l’élément courant dans l’arbre XML.
Cette propriété est disponible en lecture seulement.
TypeEntierType du noeud XML :
  • XMLLecteurAucun : L'élément en cours ne correspond pas à un noeud.
  • XMLLecteurBaliseDébut : Début de balise.
  • XMLLecteurBaliseFin : Fin de balise.
  • XMLLecteurBaliseVide : Balise vide.
  • XMLLecteurCDATA : Section CDATA.
  • XMLLecteurCommentaire : Commentaires.
  • XMLLecteurEntité : Déclaration d'une entité.
  • XMLLecteurInconnu : Type inconnu.
  • XMLLecteurProcessingInstruction : Processing instruction
  • XMLLecteurRéférenceEntité : Référence à une entité.
  • XMLLecteurTexte : Texte.
  • XMLLecteurTypeDocument : Déclaration DOCTYPE.
Cette propriété est disponible en lecture seulement.
ValeurChaîne de caractères UnicodeValeur du noeud.
Remarque : Les références à une entité sont automatiquement interprétées.
Cette propriété est disponible en lecture seulement.

Remarque : Ces propriétés peuvent être utilisées en utilisant une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire