PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV 23 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Ouvre une image dans un champ Editeur d’images.
Exemple
sFichier est une chaîne

// Ouvre le sélecteur d'images
sFichier = fSélecteurImage("", "", "Sélectionnez une image...")

SI sFichier = "" ALORS
RETOUR
FIN

// Ouverture de l'image dans le champ Editeur d'images
SI PicOuvre(EI_MonEditeur, sFichier) = Faux ALORS
Erreur(ErreurInfo())
FIN
Syntaxe
<Résultat> = PicOuvre(<Champ Editeur d'images> , <Image>)
<Résultat> : Booléen
  • Vrai si l'image a été ouverte,
  • Faux dans le cas contraire. Pour connaître le libellé de l'erreur, utilisez la fonction ErreurInfo avec la constante errMessage.
<Champ Editeur d'images> : Nom de champ
Nom du champ Editeur d'images à manipuler.
<Image> : Chaîne de caractères (entre guillemets) ou variable de type Image
Image à afficher dans le champ Editeur d'images. Ce paramètre peut correspondre à :
  • une variable de type Image.
  • le chemin d’un fichier image.
Remarques
Cette fonction est équivalente à la syntaxe suivante :
<Nom du champ Editeur d'images> = <Chemin de l'image>
<Nom du champ Editeur d'images> = <Variable de type Image>
Composantes
WINDEVEtats et Requêtes wd230pic.dll
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire