PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 23 !
  • Propriétés spécifiques à la description des variables du type Description d'Option
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Description d'Option (Type de variable)
En anglais : Option description
Une variable de type Description d'Option permet de manipuler par programmation les caractéristiques d'une option de combinaison.
Les caractéristiques de ce type peuvent être connues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Récupère la définition du type de d
d est une Définition
d = RécupèreDéfinition(ActionFichier)
// Affiche le nom du type de d
Trace(d..Nom)

// Solution 1 : lister les options de la combinaison
SI d..Type = wlCombinaison ALORS
POUR TOUT MonElément DE d..Option
Trace(MonElément..Nom)
FIN
FIN
// Solution 2 : lister les options de la combinaison
// (en utilisant le type Description d'Option)
SI d..Type = wlCombinaison ALORS
D1 est une Description d'Option
POUR TOUT D1 DE d..Option
Trace(D1..Nom)
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables du type Description d'Option

Les propriétés suivantes peuvent être utilisées pour manipuler une option de combinaison :
Nom de la propriétéType manipuléEffet
AliasBooléen
  • Vrai si l'option est un alias d'une option ou d'une combinaison d'options existante,
  • Faux dans le cas contraire.
Cette propriété est disponible en lecture seulement.
DéclarationVariable de type DéfinitionDéclaration de l'option.
Cette propriété est disponible en lecture seulement.
HéritéBooléen
  • Vrai si la combinaison est héritée d'une combinaison étendue,
  • Faux dans le cas contraire.
Cette propriété est disponible en lecture seulement.
NomChaîne de caractèresNom de l'option.
Cette propriété est disponible en lecture seulement.
ValeurTous typesValeur de l'option.
Cette propriété est disponible en lecture seulement.
ValeurAssociéeTous typesValeur associée de l'option.
Cette propriété est disponible en lecture seulement.


Remarque : Ces propriétés peuvent être utilisées en utilisant une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire