PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 23 !
  • Propriétés spécifiques à la description des variables de type Description de valeur
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Description de Valeur (Type de variable)
En anglais : Value description
Une variable de type Description de Valeur permet de manipuler par programmation la description d'une valeur d'énumération.
Les caractéristiques de ce type peuvent être connues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Récupère la définition du type de d
d est une Définition
d = RécupèreDéfinition(Poste1)
// Affiche le nom du type de x
Trace(d..Nom)
//  Lister les valeurs de l'énumération
SI d..Type = wlEnumération ALORS
POUR TOUT MonElément DE d..Valeur
Trace(MonElément..Nom)
FIN
FIN
// Autre possibilité : Utiliser une description de valeur
SI d..Type = wlEnumération ALORS
D1 est une Description de Valeur
POUR TOUT D1 DE d..Valeur
Trace(D1..Nom)
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type Description de valeur

Les propriétés suivantes peuvent être utilisées pour manipuler une description d'une valeur d'une énumération :
Nom de la propriétéType manipuléEffet
AliasBooléen
  • Vrai si la valeur est un alias d'une valeur existante,
  • Faux dans le cas contraire.
Cette propriété est disponible en lecture seulement.
DéclarationVariable de type DéfinitionDéclaration de la valeur.
Cette propriété est disponible en lecture seulement.
HéritéBooléen
  • Vrai si la valeur est héritée d'une énumération étendue,
  • Faux dans le cas contraire.
Cette propriété est disponible en lecture seulement.
NomChaîne de caractèresNom de la valeur.
Cette propriété est disponible en lecture seulement.
ValeurTous typesValeur.
Cette propriété est disponible en lecture seulement.
ValeurAssociéeTous typesValeur associée.
Cette propriété est disponible en lecture seulement.


Remarque : Ces propriétés peuvent être utilisées en utilisant une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire