PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Produits
WINDEVWEBDEV - Code ServeurWEBDEV - Code NavigateurWINDEV MobileEtats et Requêtes
Plateformes
WindowsLinuxWindows MobileUniversal Windows 10 AppAndroidWidget AndroidiPhone/iPadApple Watch
Langages
JavaPHPAjaxCode Utilisateur (MCU)Langage Externe
Bases de données
HFSQLHFSQL Client/ServeurProcédures stockéesOLE DBODBCAccès Natifs
Restaure la configuration d'un champ Tableau de bord. Cette configuration est constituée des éléments suivants :
  • position des fenêtres ou pages internes du champ Tableau de bord.
  • taille des fenêtres ou pages internes du champ Tableau de bord.
  • visibilité des fenêtres ou pages internes du champ Tableau de bord.
Remarque : Pour sauver ou de restaurer automatiquement la configuration utilisateur, cochez l'option "Mémoriser la configuration des Widgets" dans l'onglet "Détail" de la fenêtre de description du champ.
Versions 20 et supérieures
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible en WEBDEV Serveur.
WEBDEV - Code Navigateur Cette fonction est désormais disponible en code Navigateur.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 20
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible en WEBDEV Serveur.
WEBDEV - Code Navigateur Cette fonction est désormais disponible en code Navigateur.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible en WEBDEV Serveur.
WEBDEV - Code Navigateur Cette fonction est désormais disponible en code Navigateur.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Versions 22 et supérieures
WINDEV MobileiPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEV MobileAndroid Cette fonction est désormais disponible pour les applications Android.
Nouveauté 22
WINDEV MobileiPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEV MobileAndroid Cette fonction est désormais disponible pour les applications Android.
WINDEV MobileiPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEV MobileAndroid Cette fonction est désormais disponible pour les applications Android.
Exemple
WINDEV
// Demande à l'utilisateur la configuration qu'il souhaite charger
sFichier est une chaîne

// Ouvre le sélecteur de fichiers
sFichier = fSélecteur("", "", "Sélectionnez un fichier de configuration...",...
"Configuration de tableau de bord" + TAB + "*.tdbconf", "*.tdbconf")
// Si un fichier est sélectionné
SI sFichier <> "" ALORS
// Récupère la configuration contenue dans le fichier
sConfiguration est chaîne = fChargeTexte(sFichier)
// Charge la configuration
SI TDBChargeConfiguration(TDB_TableauDeBord, sConfiguration) ALORS
ToastAffiche("La configuration a été chargée", toastCourt, cvMilieu, chCentre)
SINON
Erreur("Erreur en chargement de configuration", ErreurInfo())
FIN
FIN
WEBDEV - Code Serveur
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepWeb() + ["\"] + "ConfigTDB.tdb") ALORS
sMaconfig = fChargeTexte(fRepWeb() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaconfig)
FIN
Versions 22 et supérieures
WINDEV MobileAndroidiPhone/iPad
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepEnCours() + ["\"] + "ConfigTDB.tdb") ALORS
sMaConfig = fChargeTexte(fRepEnCours() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaConfig)
FIN
Nouveauté 22
WINDEV MobileAndroidiPhone/iPad
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepEnCours() + ["\"] + "ConfigTDB.tdb") ALORS
sMaConfig = fChargeTexte(fRepEnCours() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaConfig)
FIN
WINDEV MobileAndroidiPhone/iPad
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepEnCours() + ["\"] + "ConfigTDB.tdb") ALORS
sMaConfig = fChargeTexte(fRepEnCours() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaConfig)
FIN
Syntaxe
<Résultat> = TDBChargeConfiguration(<Tableau de Bord> , <Configuration>)
<Résultat> : Booléen
  • Vrai si la configuration a été chargée.
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Tableau de Bord> : Chaîne de caractères (avec ou sans guillemets)
Nom du champ Tableau de bord à manipuler.
<Configuration> : Chaîne de caractères (avec guillemets)
Configuration à restaurer. Cette configuration est le résultat de la fonction TDBSauveConfiguration.
Attention : Si le format de ce paramètre est invalide ou ne peut pas être appliqué au champ Tableau de bord (par exemple parce que les fenêtres/pages internes ou le nombre de colonnes ne correspondent pas), <Résultat> vaut Faux.
Remarques
  • Les Widgets déclarés visibles depuis la dernière sauvegarde doivent être visibles au chargement de la configuration.
  • Linux Remarque : Le champ Tableau de bord est disponible en Linux uniquement dans les sites WEBDEV Linux. Le champ Tableau de bord n'est pas disponible dans les applications WINDEV pour Linux.
Liste des exemples associés :
WD Tableau de bord Exemples didactiques (WINDEV) : WD Tableau de bord
[ + ] L'exemple "WD Tableau de bord" est un exemple didactique sur l'utilisation du champ Tableau de bord.
Cet exemple présente comment :
- manipuler le champ en mode "édition",
- sauver/charger une configuration,
- configurer le champ (configuration initiale, ajout / suppression de widgets, ...),
- rafraîchir un widget,
- etc.
WW_TableauDeBord Exemples didactiques (WEBDEV) : WW_TableauDeBord
[ + ] L'exemple "WW_TableauDeBord" est un exemple didactique sur l'utilisation du champ Tableau de bord.
Cet exemple présente comment :
- manipuler le champ en mode "édition",
- sauver/charger une configuration,
- configurer le champ (configuration initiale, ajout / suppression de widgets, ...),
- rafraîchir un widget.
Composantes
WINDEVEtats et Requêtes wd220obj.dll
WEBDEV - Code Serveur wd220page.dll
WEBDEV - Code Navigateur WDJS.DLL
Linux wd220obj.so
Android wd220android.jar
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire